Trouble since September update

Since the september update, I’m having trouble playing any video format a.f.a.i.k. Trying to play anything results in a :pensive: emoji

output of “paste-log ~/.kodi/temp/kodi.log”:

Might be related to the following thread: Startup ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown

edit: running on RPi 2, uname -a : Linux osmc 4.2.1-1-osmc #1 SMP PREEMPT Wed Sep 23 17:57:49 UTC 2015 armv7l GNU/Linux

Please upload a debug log


Will do, just got around another issue. This time, nothing that I did could have triggered it (that I know of, not even a minor system change or anything). The only error I got before was the original post above. Before that, from time to time, OSMC would be frozen when I turned on the tv and switch to the related HDMI input. Replugging the power would make it boot again and everything would be fine.

Then, in the original post above, after the september update, no content was playable.

Now, whenever I try to boot the RPi2 + OSMC, I get this: - YouTube

Any clue?

edit: the first line on booting says:
Failed to start Remount Root and Kernel File System

Your system seems corrupt. I would fsck the root partition.


By plugging the MicroSD into a laptop and running fsck on that disk?

That will work. You can also do it by setting an option in cmdline.txt.


edited cmdline.txt > fsck /dev/mmcblk0 >

ext2fs_check_if_mount: Can’t check if filesystem is mounted due to missing mtab file while determining whether /dev/mmcblk0 is mounted.
fsck.ext2: Device or resource busy while trying to open /dev/mmcblk0
Filesystem mounted or opened exclusively by another program?

edit: ran mount -t proc proc /proc, now fsck /dev/mmcblk0 says >
/dev/mmcblk0 is in use. Cannot continue, aborting.

mmcblk0 is not a partition, it’s a block device. You want to fsck mmcblk0p2.

solved by taking out the sd card, editing cmdline.txt on a different computer and adding init=/bin/sh, then plugging it back in the RPi, booting straight into shell, running mount -t proc proc /proc, then: fsck /dev/mmcblk0p2. Took the power cable out, sd card out, edit cmdline.txt again to not include init=/bin/sh, stuck it back in, booting fine now.

Sam, if you have any spare time, could you explain why this worked? I’m not familiar with these ‘low-level’ commands. Especially the mount -t proc proc /proc part

Is this sufficient?

whatever happened, playback is back to normal after the fix I mentioned above.

Well, you seem to have done it, which is good!

init=/bin/sh boots you in to single user mode shell
fsck /dev/mmcblk0p2 performs a filesystem check on your root partition. In future we are going to automate this.
mount -t proc proc /proc mounts procfs. Not necessary for the steps you did today, but doesn’t cause any problems.

How is your power supply? I’d make sure it’s good so that you can hopefully avoid this situation again



The power supply is an original RPi2 power supply, no rainbow icon in the top border indicating a bad PSU, no performance drops or anything. Has been running smoothly for about 2 months now. Could it possibly have something to do with not having any heatsink whilst being mounted in a case?

I see from a debug log you posted you have your Pi 2 clocked to Turbo. Try dropping that back to Normal.

Many Pi 2’s (including my own) are not stable in Turbo. I get random hard freezes on mine in Turbo (with a top notch power supply) but it works perfectly at Normal. This is very likely the root cause of your issue.

Cheers! I’ve put it back to Normal and not having an issue at all. When I got back home today, it was frozen again like you mentioned above. Has been running for a few hours now but not expecting anything bad to happen.