Trouble to mount my logical volume since the last update

Hi everyone, I don’t know if it’s the right place to post my request but since the last OSMC update (18 September 2022 ) I’m not able to mount my logical volume.

I have a Raspberry Pi 3 Model B Rev 1.2 with the last version of OSMC.

I have 3 HDD (2 X 4To + 1 X 8To). The smallest are put together to form a 8To logical volume and store all my songs and movies. The 8 To is a backup (I use crontab to rsync a perfect copy).

osmc@RASPBERRYPI:/boot$ sudo lvscan
ACTIVE ‘/dev/NASvg/NASlv’ [<7.28 TiB] inherit

osmc@RASPBERRYPI:/boot$ sudo lvdisplay
— Logical volume —
LV Path /dev/NASvg/NASlv
LV Name NASlv
VG Name NASvg
LV UUID 4kw47I-OA5y-omdn-QA4g-Hqqp-an22-lI23rF
LV Write Access read/write
LV Creation host, time RASPBERRYPI, 2022-05-18 18:45:44 +0200
LV Status available
# open 0
LV Size <7.28 TiB
Current LE 1907658
Segments 2
Allocation inherit
Read ahead sectors auto
- currently set to 256
Block device 254:0

Since the last update, the auto mounting of my logical volume at the start of the Pi failed, I tried manually but same result :

osmc@RASPBERRYPI:/boot$ sudo mount -t exfat /dev/NASvg/NASlv /mnt/NAS
mount: /mnt/NAS: can’t read superblock on /dev/mapper/NASvg-NASlv.

I try to fsck.exfat the LV and it seems to be ok :

exfatfsck 1.3.0
Checking file system on /dev/NASvg/NASlv.
File system version 1.0
Sector size 512 bytes
Cluster size 128 KB
Volume size 7452 GB
Used space 3687 GB
Available space 3765 GB
Totally 5844 directories and 59006 files.
File system checking finished. No errors found.

Here my logs :

I have a back up so I can reset my LV but I would like to avoid this solutoin because it’s a big pain and a little bit risky to copy more than 4To through the usb of the pi…

Thanks for your help

PS : Sorry for my english, I’m french ^^

Maybe it doesn’t like the new Kernel driver. You could try…

osmc@RASPBERRYPI:/boot$ sudo mount -t exfat-fuse /dev/NASvg/NASlv /mnt/NAS

Although I’m not sure what the point of combining these drives would be. It seems like it would be simpler to just add both drives in Kodi inside the same source location which makes Kodi display them combined as if they where one browsing through ‘videos’. Or you could just use a library in which the actual locations are irrelevant.

Thank you, I will try to use the exfat-fuse option ASAP and will tell you if it works (I’m not at home for the moment)

I have combined this drives beacause I didn’t know about the other solutions and because It’s a comfort to have only one mount point on Samba and to make the rsync copy.
I can browse all my stuff in one Movies directory, one Music directory, etc

A this time, If I want to keep my data I need to use the combined drives…

Thank you for your help

osmc@RASPBERRYPI:/boot$ sudo mount -t exfat-fuse /dev/NASvg/NASlv /mnt/NAS

does work perfectly.

1 Like