Trouble with Samba shares on old Blu-Ray player since December update

I’ve been using my Kodi OSMC raspberry pi 3 as a server and my LG BD Player BD570 (2010) as the client to play media files on a HD that is USB connected to the Kodi box.
The LG BD player uses some early version of Samba, since the log-on screen says “CIFS log-on.”
This has worked fine up until the December update. The LG BD player would see the Kodi box on the network and I could connect using the default passwords for OSMC (osmc/osmc).
Now, the LG BD player stills sees the Kodi box, but when I try to connect with default password, I get “incorrect password.”
However, I can still connect with Samba shares with the same default password on a laptop I have running Ubuntu, so I don’t think the password is the issue.
I realize that in the December update there is the option of setting the maximum Samba version setting (v1, v2, v3 or none.)
I’ve tried all the settings and still get the same “incorrect password” response.
Suggestions for further troubleshooting? solutions?
Thank you

That is for OSMC as a samba client doesn’t have any impact on the samba server.

We could try to do some changes on the server and also some check when you connect from Ubuntu. But need some command line knowledge

I know how to open the Linux command line and execute commands if you give them to me.

Can we start with ssh into the Pi and post what you get with

cat /etc/samba/smb.conf | paste-log

and if you have it:

cat /etc/samba/smb-local.conf | paste-log

For the first, it creates a web-page with the following content

[global]

# If you require a fully custom smb.conf create smb-local.conf instead of editing smb.conf so your
# configuration will not be overwritten by samba upgrades. You can use smb.conf as a template by
# copying it to smb-local.conf then removing the config file line below in the new file. If you only
# need to add some additional shares see smb-shares.conf below for a simpler way to do this.

    config file = /etc/samba/smb-local.conf

    workgroup = WORKGROUP
    security=user
    follow symlinks = yes
    wide links = no
    unix extensions = no
    lock directory = /var/cache/samba
    load printers = no
    printing = bsd
    printcap name = /dev/null
    disable spoolss = yes
    log level = 1
    map to guest = bad user
#   usershare template share = automount template

# Automount template disabled to work around a samba bug causing crashes accessing external drives.

    read raw = Yes
    write raw = Yes
    strict locking = no
    min receivefile size = 16384
    use sendfile = true
    aio read size = 2048
    aio write size = 2048
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=131072 SO_SNDBUF=131072

[osmc]
    browsable = yes
    read only = no
    valid users = osmc
    path = /home/osmc
    comment = OSMC Home Directory

[automount template]
    browseable = yes
    -valid = no
    valid users = osmc
    path = %P
    hide files = /$RECYCLE.BIN/System Volume Information/desktop.ini/thumbs.db/

# Add custom shares in smb-shares.conf instead of editing smb.conf so they will not be
# overwritten by samba updates. You can only add new shares to smb-shares.conf, not change
# the default shares or global options. If you need full control see smb-local.conf above.

include = /etc/samba/smb-shares.conf
***

For the second:
message “Document not found.”

The idea is you just post that URL so we can look at it,but no harm :wink:

Nothing strage there. Could you enable debug logging, restart the Pi, try to connect from the BD player then get logs as described here: https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

Edit: Please delete the line in /etc/samba/smb.conf which starts socket options. SMB issue since last upgrade - #19 by jra_samba

OK I deleted that line in the samba config file, but it made no difference for my current problem.

I have the URL for the log I made according to your instructions. Should I paste it here publicly or do I submit it in private?
Thanks.

Here is fine

https://paste.osmc.tv/kopapozemo

Perhaps we get a clue if we collect more detailed nmbd + smbd debug logs:

  1. Starting on OSMC device:
    sudo systemctl stop samba
  2. sudo rm /var/log/samba/log.*
  3. sudo chmod 777 /etc/default
  4. sudo echo 'SMBDOPTIONS=-d 3' > /etc/default/samba
  5. sudo echo 'NMBDOPTIONS=-d 3' >> /etc/default/samba
  6. sudo systemctl start samba

Now, reproduce your issue trying to access your OSMC samba server with the BD player

  1. Continue on the OSMC device:
    sudo systemctl stop samba
  2. sudo paste-log /var/log/samba/log.nmbd (and provide the returned URL here in the forum)
  3. sudo paste-log /var/log/samba/log.smbd (and provide the returned URL here in the forum)
  4. sudo rm /etc/default/samba
  5. sudo chmod 755 /etc/default
  6. sudo systemctl start samba

-d 3” is the log level; if you want you can make a second collection and try highest log level 10 and provide these URLs as well.

2 Likes

log.nmbd -d 3: https://paste.osmc.tv/yuhanuzucu
log.nmbd -d 10: https://paste.osmc.tv/ihidacarag
log.smbd -d 3: https://paste.osmc.tv/jemovifawa
log.smbd -d 10: https://paste.osmc.tv/vahujeqihi

Well I believe we are all no Samba experts and can mainly guess. But for me this looks like either really wrong password used or the password security protocol issue. I would suggest the following:

  1. Set new password on OSMC with sudo smbpasswd -L -U osmc and then be 100% sure to use that password on your BlueRay player.

If that doesn’t solve the issue allow weak password protocol

  1. sudo systemctl stop samba
    sudo nano /etc/samba/smb.conf
    add the line lanman auth = yes and ntlm auth = Yes
    sudo systemctl start samba
[2018/01/24 18:47:44.274628, 10, pid=3495, effective(0, 0), real(0, 0), class=passdb] ../source3/passdb/pdb_get_set.c:557(pdb_set_group_sid)
  pdb_set_group_sid: setting group sid S-1-5-21-2634662373-4275645912-3482149848-513
[2018/01/24 18:47:44.274735,  4, pid=3495, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:438(pop_sec_ctx)
  pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 0
[2018/01/24 18:47:44.274823,  2, pid=3495, effective(0, 0), real(0, 0)] ../libcli/auth/ntlm_check.c:424(ntlm_password_check)
  ntlm_password_check: NTLMv1 passwords NOT PERMITTED for user osmc
[2018/01/24 18:47:44.274897,  3, pid=3495, effective(0, 0), real(0, 0)] ../libcli/auth/ntlm_check.c:443(ntlm_password_check)
  ntlm_password_check: Lanman passwords NOT PERMITTED for user osmc
[2018/01/24 18:47:44.274967,  4, pid=3495, effective(0, 0), real(0, 0)] ../libcli/auth/ntlm_check.c:480(ntlm_password_check)
  ntlm_password_check: Checking LMv2 password with domain 
[2018/01/24 18:47:44.275110,  4, pid=3495, effective(0, 0), real(0, 0)] ../libcli/auth/ntlm_check.c:509(ntlm_password_check)
  ntlm_password_check: Checking LMv2 password with upper-cased version of domain 
[2018/01/24 18:47:44.275217,  4, pid=3495, effective(0, 0), real(0, 0)] ../libcli/auth/ntlm_check.c:537(ntlm_password_check)
  ntlm_password_check: Checking LMv2 password without a domain
[2018/01/24 18:47:44.275321,  4, pid=3495, effective(0, 0), real(0, 0)] ../libcli/auth/ntlm_check.c:568(ntlm_password_check)
  ntlm_password_check: Checking NT MD4 password in LM field
[2018/01/24 18:47:44.275419,  3, pid=3495, effective(0, 0), real(0, 0)] ../libcli/auth/ntlm_check.c:589(ntlm_password_check)
  ntlm_password_check: LM password and LMv2 failed for user osmc, and NT MD4 password in LM field not permitted
[2018/01/24 18:47:44.275506,  4, pid=3495, effective(0, 0), real(0, 0)] ../source3/smbd/sec_ctx.c:216(push_sec_ctx)
................................
[2018/01/24 18:47:44.282507,  5, pid=3495, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth.c:252(auth_check_ntlm_password)
  check_ntlm_password: sam authentication for user [osmc] FAILED with error NT_STATUS_WRONG_PASSWORD
[2018/01/24 18:47:44.282718,  2, pid=3495, effective(0, 0), real(0, 0), class=auth] ../source3/auth/auth.c:315(auth_check_ntlm_password)
  check_ntlm_password:  Authentication for user [osmc] -> [osmc] FAILED with error NT_STATUS_WRONG_PASSWORD
[2018/01/24 18:47:44.282802,  5, pid=3495, effective(0, 0), real(0, 0)] ../source3/auth/auth_ntlmssp.c:188(auth3_check_password)
  Checking NTLMSSP password for \osmc failed: NT_STATUS_WRONG_PASSWORD
[2018/01/24 18:47:44.282898,  3, pid=3495, effective(0, 0), real(0, 0)] ../source3/smbd/error.c:82(error_packet_set)
  NT error packet at ../source3/smbd/sesssetup.c(937) cmd=115 (SMBsesssetupX) NT_STATUS_LOGON_FAILURE
[2018/01/24 18:47:44.282983,  5, pid=3495, effective(0, 0), real(0, 0)] ../source3/lib/util.c:171(show_msg)
[2018/01/24 18:47:44.283032,  5, pid=3495, effective(0, 0), real(0, 0)] ../source3/lib/util.c:181(show_msg)
3 Likes

Solution 1 did not work, but solution 2 did. So thanks to everyone who helped diagnose this issue!

2 Likes

Found this via Google… I was having the same problem with my OSMC samba share to a Humax HDR-Fox-T2 PVR client having stopped working with the recent OSMC updates. Solution 2 fixed it for me. Thanks for the the solution

1 Like

Confirming that this solved the issue I’ve been having for months not being able to connect to my Vero 4K from Windows which was discussed here Can't access Vero 4K/OSMC from Windows - #154 by fzinken

Thanks @fzinken