TrueHD Decode Issue

Hey there,

Due to some known issues on certain UHD films, namely Guardians of the Galaxy 2 and POTC when using TrueHD passthrough (the sound drops at certain points or Kodi will flat out crash) I’ve set Kodi on the Vero 4K to Decode TrueHD instead of passthrough.

This works to resolve the issue with those films, however I’m having another issue. Sometimes when playing a file with TrueHD audio, I will get a horrible and super loud noise come from the rear speakers. It only happpens about 10% of the time, and only when you start playing a file, it does not happen during playback. If the noise has started, trying to pause and restart or skip forward does not resolve the issue.

I have also noticed this issue only happens if I set my speaker setup to 7.1 instead of 5.1 in Kodi. I only have a 5.1 speaker setup but my Amp is 7.1 and I’ve read you should always set it to what your Amp expects and it will deal with the rest.


Don’t know if it means much, since I’m pretty clueless but I noticed in the log it says:

23:54:05.285 T:4040160000 ERROR: CAESinkALSA::Initialize - failed to initialize device “@:CARD=AMLM8AUDIO,DEV=0”

and this is the time I got the noise, the next time I played the file that error is not there, and there was no horrible sound.


Hopefully the issue is now addressed

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Hey Sam,

Sadly this did not resolve the issue, initially it was looking good since it took me about 20 attempts of playing a Atmos/TrueHD file before the audio screeching sound happened.

I thought it might be HDMI cable related since it only seems to happen when you start a file, so maybe the vero is having some form of issue syncing up with the Amp, however I’ve tried 5 cables now and that has not resolved the issue either.

The scary thing in all this is just how loud it can be, I’ve been testing with my Amp set at -70 but the first time it happened I had it at a normal volume and the screeching sound scared the crap out of me.

I’m more than happy to help with testing but for now I’ve put passthrough back on because I can’t risk it doing that if someone else is using the Vero.

@gillious Hi, what brand and model is your AVR?

@JimKnopf It’s a Yamaha RX-V679.

Thank you.

Could you post a log playing that clip when the error is not there, please? The log you posted says it can’t initialize either @:card=AMLM8AUDIO or default. I’ve never seen that befaore. Normally it will fall back to ‘sysdefault’.

Sure thing,

The file played without issue until the very last attempt where I stopped and uploaded the log. I put debug logging on if that helps also.

Oddly this time I don’t see any “failed to initialize device” in the log despite the fact the last play of the file produced the upsetting audio noise again.

@grahamh I did some more testing and made another log, no debug mode on this time since I’m not sure if you want that or not. It was only the last playback of dolby_amaze_lossless-DWEU.m2ts that caused the sound issue, the only thing I can see in the log different from the other times when it played without issue is WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer


Try upgrading again per the instructions above. the latest build is working for me.

1 Like

Don’t know what you did, but that seems to have resolved it. I kept trying to get it to do the sound until I got bored and gave up. I’ll of course post back if it happens again but it looks like you might have nailed it.

Many Thanks :slight_smile:

That’s indeed good news and confirms the results we’ve had so far… Keep us posted, if any issue should come back. :+1:t2:

Sadly, the issue has returned. It seems to happen less often but it totally caught me off guard when I started the first movie of the day.


dolby_amaze_lossless-DWEU.m2ts - all play’s are fine, until the last one in the log where the noise happens again.

I don’t know why it’s failing but you should get better results by turning on TrueHD passthrough. have you tried that with the latest kernel?

If that doesn’t work, could you share the contents of two alsa conf files.

cat /usr/share/alsa/alsa.conf | paste-log
cat /usr/share/alsa/cards/AML-M8AUDIO.conf | paste-log

TrueHD passthrough seems fine, however the main reason I was not using it is that a few UHD movies have known issues with audio dropouts and the suggested fix for Kodi was to use Decode instead of passthrough. I guess it’s not a huge issue I can just enable passthrough and disable it when watching those specific movies and make sure my Amp is very low volume before I start it incase the screeching sound happens.

Those two confs for you are:

Thanks could you also post debug logs. ie turn on debug logging in System-settings before playing tracks.

Sure log is :

This time it was just the 2nd attempt playing dolby_amaze_lossless-DWEU.m2ts that caused the sound issue.

Not sure if it means anything but I notice in the log that the 2nd time I played the file it says : CAESinkALSA::GetChannelLayout - Input Channel Count: 2 Output Channel Count: 2

and the first time it said:

Input Channel Count: 8 Output Channel Count: 8

Thanks again. I don’t understand why it tries to open the file in 2-channels but will look harder and play that clip a few times here to check.

The screech is probably related to another issue we are looking into.

Yea it’s a strange one, as I say most of the time the file will play fine with all the channels working and no issues. It seems totally random as to when it will just start making a horrible sound from the two rear speakers, when it happens the FL,FR speakers are fine.

Now I think of it - you said you have 5.1 speakers. Set that in kodi and you should be good.

Yea setting 5.1 does seem to fix it, but I read somewhere that might cause issues with low volume on the rears when you playback a 5.1 TrueHD file instead of a 7.1 because it won’t downmix them correctly. Not sure if this is the case or not?