Trying to boot Pi 4 via composite - Stuck on splash

Hey all, just picked-up a Pi 4 to test in my car. I wanted to get Wireguard setup but couldn’t get it working on the Pi 3.

I understand composite is disabled by default but failing at booting after enabling it in the config.

Just flashed my SD again after getting stuck at the splash screen but experiencing the same problem again.

I suspect maybe it’s outputting via HDMI as well but I can’t see it (I also don’t have a micro-HDMI cable).

I’ve simply added enable_tvout=1 to the config and noticed after initial format and reboot it creates a config-user.txt (which I’ve found gets overwritten if I try create right after imaging the SD)

Is there anything else I can add in the config to ensure it’s only outputting to composite? One nice bonus is there’s no longer interference showing up on the screen with data transfer!

It’s also not on a network yet but I can certainly set it up on a bench and SSH into it if config changes won’t make a difference.

Try to connect to network and upgrade to staging

Thanks, same issue though. Looks like that person couldn’t get it working either :frowning:

Okay, picked up a micro-HDMI adapter and can confirm it’s outputting fine to a HDMI display.

Have run the kernel update again (from a fresh install) but still nothing on composite out, just the splash screen.

I did see that the MediaCenter process is running, just not seeing it on this output. Haven’t tested connecting both HDMI and composite at the same though (that’s not an easy task given my garage setup)

Here are the only commands I could find to try, not too useful since it’s saying 0 attached devices. I did also try hdmi_ignore_hotplug=1 but made no difference (composite video still worked but still just showing the splash screen)

tvservice -s
state 0x40001 [NTSC 4:3], 720x480 @ 60.00Hz, interlaced
tvservice -l
0 attached device(s), display ID's are :

Here are some logs;


Are you seeing a black screen or the terminal output?
If you see only a black screen what happens if you run sudo systemctl disable mediacenter and reboot do you see terminal screen?

All I’m seeing is this;

Well, I assume this means it’s running?

ps aux | grep media
root       431  0.0  0.0   6744  2572 ?        Ss   12:45   0:00 /bin/bash /usr/bin/mediacenter
PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND                                                                  
497 osmc      20   0  495152 111952  62612 S  23.5   2.9   0:24.83 kodi.bin

I will try that now

I installed Plex to see if that’d appear after telling it to launch at startup and now trying RetroArch to see whether that loads when starting manually

I hope you can appreciate how “not easy” this was (it wasn’t hard, but it also wasn’t easy).


I don’t have a solution for this.

Did some more testing

LibreELEC doesn’t work, no output at all on composite

Raspberry Pi OS Desktop works fine so installed Raspberry Pi OS Lite with Kodi (it installed 18.9 for some reason) set to auto start and that works

uname -a
Linux raspberrypi 5.10.63-v7l+ #1459 SMP Wed Oct 6 16:41:57 BST 2021 armv7l GNU/Linux
tvservice -s
state 0x40000 [NTSC 4:3], 720x480 @ 60.00Hz, interlaced
tvservice -l
1 attached device(s), display ID's are : 
Display Number 3, type Composite

Tried again with the November update

Splash screen shows then goes black

tvservice isn’t supported with the vc4-kms-v3d driver

Tried changing to vc4-fkms-v3d and get output but playback is pretty bad

So found a similar issue posted on LibreELEC forums

add “composite=1” to the kms dtoverlay in config.txt


enable tvout in config-user.txt


set your desired mode in cmdline.txt (on the same line after “quiet”). eg for PAL;


or for NTSC;


Played around with this and output does work but playback is still quite bad and even stops completely on a basic 720p VP9 video

1 Like

I’ve been having the same issue. I can get composite out on Rasperry Pi OS, but not from OSMC. I tried configs similar to shown here.
I wasn’t going to reply, until I saw the photo, and it looks like you’re trying to set this up on a Nissan Stagea, exactly the same as I’m working on!

So, I was curious if you ever got any further, and what you settled on for your solution?

I did pick up an HDMI to composite, and it seems to work, but would rather just use the composite out directly. However now I’m also bit stuck trying to find a skin for Kodi (or other solution entirely maybe) where the text is readable and and menu usable on the small SD display.

For Touch you could try this skin: