Trying to reinstall OSMC on a VERO 4K

Hi All,
as the title suggests, I want to reset my VERO 4K to factory default.
I’ve follwed the guide here.

However, the VERO simply booted up normally. I then tried the troubleshooting guide, booting the device with the reset button pressed - now i get “waiting for root filesystem device” and then after a while “fatal error root filesystem device not found”

In the troubleshooting guide, it says I’m supposed to “rename the file ‘kernel.img’ to ‘recovery.img’”, only there is no such file on my USB Stick. If I use the OSMC installer to write the image, I can see the following files:


If I use Win32DiskImager, I can’t access the USB drive at all.

Any idea what I’m doing wrong here???


You have downloaded the wrong image. You have downloaded the image for Vero 1.

Hi Sam,

oops - that would it explain it :slight_smile:

Downloaded the right image, renamed the file and tried again - still no luck.
I can either boot up the machine with the “reset button” pressed, I then get a blue screen with “please stand by” no matter how long I keep button pressed, or without pressing the button, I then get the same mesage as in the first post…

  • Erik

I also had problems with that. I just did

rm -rf ~/.kodi
rm /walkthrough_completed

Plus any content you might have stored in ~/Movies, Pictures, TV Shows. That should be it, unless you added anything to fstab.

1 Like

No luck with that either…:sob:

What does that mean?

  1. The files were there and you removed them; or
  2. The files were not there?

Sorry, that was a bit unclear…
Yes and no:
rm -rf ~/.kodi: OK, no error messages etc.
rm /walkthrough_completed: File not found

  • Erik

Please try using a micro-SD card.

Tried an SD card - worked like a charm! Thanks for the help and suggestions, guys - really appreciate it!

  • Erik
1 Like

Glad to hear this.
Your USB stick might be duff.