Trying to set up SMB Sharing for the first time


#21

So that looks good:

  1. Check in Settings -> Services -> SMB Client -> That Max Protocol version is set to SMBv3

If that is the case and you can still not connect from within Kodi I suggest to look at autofs ([HOW-TO] Mounting network shares with autofs (alternative to fstab))

It’s getting a bit late here, so we either need to continue tomorrow or someone else picks up where we are now.


#22
  1. Check in Settings -> Services -> SMB Client -> That Max Protocol version is set to SMBv3

Its set to v1 in win and osmc ( I thought thats what you have to do)


#23

Thats what you have to do to enable browsing (but as you know what to connect to you don’t need browsing) and as the smbclient connected with smb3 I suggest to also set that in Kodi.


#24

setting v3 on win and kodi worked and now I can see the media aka torrent_dump folder but all folders inside the media folder are empty. Is this just a permission issue or do I have to just delete folders and only have files in the media folder

Thanks for help and good night. My next step is to get autofs working because of better performance but doing baby steps.

Update: Folders are visible but empty and the .mkv files that are not in folders are not visible at all.


#25

Do you mean in the “add source” step? During “add source” only folders will be shown.
Files will be either shown via the library or the “Files” menu after you added the source (normally you add the main folder)

Good night for real now


#26

Oh yea that’s it all seems to work now

Thanks again


#28

Congrats, let me know when you have problems with autofs


#29

configuring autofs looks a bit scary so I’ll definitely appreciate it If you hold my hand going through it


#30

Read the tutorial that we created. It isn’t that hard. But if you think it’s scary, it will be… So think it’s easy :wink:


#31

@fzinken

Now I’m trying to add a whole drive the same way I did with my media folder yesterday and its giving me some issues. Should It work ? Do I have to pay attention to something specific ?


#32

I assume you mean a root folder of a drive that you have shared, or?

Is it shown via smbclient? If yes all should work as before


#33

Domain=[DESKTOP-B0CH2VF] OS= Server=

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    C$              Disk      Default share
    D$              Disk      Default share
    F$              Disk      Default share
    G               Disk
    G$              Disk      Default share
    H$              Disk      Default share
    I$              Disk      Default share
    IPC$            IPC       Remote IPC
    Media           Disk
    print$          Disk      Printer Drivers
    Torrent_Dump    Disk

one of the G drives is the one I dont know if the one $ or not


#34

The default shares are not accessible so it should be G.
To avoid confusion I suggest to give it a full name like drive_G.

If you have set the user permissions like you had on the others it should just work


#35


#36

As fzinken wrote before:


#37

@k2u3 so you are all up and working now after the tip from @ooZee?


#38

Yes, funny enough yesterday I didn’t change that and it still worked when changing SMB v1 for v3