Trying to set up SMB Sharing for the first time


#1

I tried to set up SMB sharing between my window 10 machine and the vero as you see from the screenshot I messed up and now I cannot edit or delete this

Also I use Windows account to log in to my PC so I don’t know how to configure username and password.

I was using @grahamh guide

Enabled SMB 1 on pc and vero


#2

Try deleting the source, from sources.xml if necessary, and start again adding it.


#3

You’ll delete the source from the settings>file manager menu


#4

File manager looks like this so I guess I have to do what @grahamh said over SSH ?

Do you mind telling me how to navigate to sources.xml via ssh and what’s the edit command ?


#5

nano ~/.kodi/userdata/sources.xml

Find the relevant entry and delete everything between and including <source> and </source>.

then

sudo systemctl restart mediacenter


#6

sources.xml looks like this:

<sources>
    <video>
        <default pathversion="1"></default>
        <source>
            <name>Auto-mounted drives</name>
            <path pathversion="1">/media/</path>
            <allowsharing>true</allowsharing>
        </source>
    </video>
    <music>
        <default pathversion="1"></default>
        <source>
            <name>Auto-mounted drives</name>
            <path pathversion="1">/media/</path>
            <allowsharing>true</allowsharing>
        </source>
    </music>
    <files>
        <default pathversion="1"></default>
    </files>
</sources>

Nothing to edit I guess ? Mybe Its just a visual glitch in the menu ?

What ?! I’m posting something different than : Auto-mounted drives /media/ true Auto-mounted drives /media/ true but the forum auto edits it


#7

You need to quote anything with <> in it. Have done it for you.

So try to add your shared folder again.

Well, yes, it normally says Windows Network (SMB).


#8

Does this look ok to you?

Still I don’t know what to do with username and password because as said I’m logged in with a windows account and just unlock the machine with a pin at startup


#9

Create a local user just for the file sharing


#10

created a user osmc gave it permission to read my media folder added everything to osmc but I still get " Connection time out error" I must be doing some really dumb mistake I imagine.

I never set up any local file sharing before.

All I have to do on win10 is right click the folder select properties -> sharing -> share and add the user osmc to the list and assign read permission correct ?


#11

To be honest, haven’t tried myself, but yes I assume that should be good enough.
To avoid a possible issue I would recommend you try with the IP address instead of the name.
If also that is failing next suggestion is to jump to the command line to run some test commands.


#12

I entered the IP under server name and the actual name under Shared folder ( Please check the screenshot above if I did it correctly )


#13

Ah now I see it, you put the computer name into the shared folder.
The Computer name is reflected by the IP address already. So folder should only be \Media


#14

Tried what you said sadly didnt work If I can do some tests over ssh tell me what and ill do. Thanks <3


#15

Same error?

Install smbclient sudo apt-get install smbclient
Run it with smbclient -U osmc -L 192.168.88.252 you should be asked for password after entering and then be shown the list of shared folders.


#16

protocol negotiation failed: NT_STATUS_CONNECTION_RESET

Is what I get after typing in the password


#17

try smbclient -m 3 -U osmc -L 192.168.88.252


#18

osmc@osmc-Ignatius:~$ smbclient -m 3 -U osmc -L 192.168.88.252
WARNING: Ignoring invalid value ‘3’ for parameter ‘client max protocol’
WARNING: The “syslog” option is deprecated
Enter osmc’s password:
protocol negotiation failed: NT_STATUS_CONNECTION_RESET


#19

Sorry, smbclient -m smb3 -U osmc -L 192.168.88.252


#20

Domain=[DESKTOP-B0CH2VF] OS=[] Server=[]

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    C$              Disk      Default share
    D$              Disk      Default share
    F$              Disk      Default share
    G$              Disk      Default share
    H$              Disk      Default share
    I$              Disk      Default share
    IPC$            IPC       Remote IPC
    Media           Disk
    print$          Disk      Printer Drivers
    Torrent_Dump    Disk

Connection to 192.168.88.252 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled – no workgroup available
osmc@osmc-Ignatius:~$

The Torrent_dump map is what I try to access it should be the same as media