Trying to unstall firmware for ralink wifi.... are you root?

I’m trying to install firmware for relink wifi adapter with sudo apt-get update && apt-get install firmware-relink but I get this error at the end… could not open lock file var/lib/dpkg/lock -open (13: permission denied) unable to lock the administration directory (/var/lib/dpkg/) are you root … I have no clue what this means can anyone help thanks

sudo is required for both commands here.

@ActionA sudo after each word you mean ??

Look how i fixed your command in my post.

@ActionA ah I see thanks mate ill try it now thanks

It might benefit you to spend a little time with one of the tutorials here -

@ActionA its saying this now mate ??? any ideas ??
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

@ActionA I’m trying to get my 5ghz dongle to work mate its a mt7610u ralink. now mediatec I think. do you have any ideas on how to compile driver from scratch ???

Please post the entire error message, you seem to have left part of it out, but I suspect the problem is that you’re trying to install a firmware package that conflicts with the firmware files we already have on the system in another package.

Have you tried running updates via Ethernet and then check to see if your adaptor works ? Support for that adaptor should have been added in the most recent update.

@ActionA yes ive tried the Ethernet update mate its a no go ill try it again and sendthe whole message ok

@ActionA osmc@osmc:~$ sudo apt-get update && sudo apt-get install firmware-ralink
Ign jessie InRelease
Hit jessie-updates InRelease
Hit jessie/updates InRelease
Hit jessie Release.gpg
Hit jessie Release
Hit jessie InRelease
Get:1 jessie-updates/main armhf Packages/DiffIndex [643 B]
Hit jessie-updates/contrib armhf Packages
Hit jessie-updates/non-free armhf Packages
Hit jessie-updates/contrib Translation-en
Get:2 jessie-updates/main Translation-en/DiffIndex [229 B]
Hit jessie-updates/non-free Translation-en
Hit jessie/updates/main armhf Packages
Hit jessie/main armhf Packages
Hit jessie/contrib armhf Packages
Hit jessie/updates/contrib armhf Packages
Hit jessie/non-free armhf Packages
Hit jessie/updates/non-free armhf Packages
Hit jessie/contrib Translation-en
Hit jessie/updates/contrib Translation-en
Hit jessie/main Translation-en
Hit jessie/updates/main Translation-en
Get:3 jessie/main armhf Packages/DiffIndex [2023 B]
Hit jessie/non-free Translation-en
Hit jessie/updates/non-free Translation-en
Ign jessie/main Translation-en
Fetched 2895 B in 18s (159 B/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
Suggested packages:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/22.2 kB of archives.
After this operation, 103 kB of additional disk space will be used.
(Reading database … 29046 files and directories currently installed.)
Preparing to unpack …/firmware-ralink_0.43_all.deb …
Unpacking firmware-ralink (0.43) …
dpkg: error processing archive /var/cache/apt/archives/firmware-ralink_0.43_all.deb (–unpack):
trying to overwrite ‘/lib/firmware/rt3290.bin’, which is also in package wireless-firmware-osmc 1.1.0
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

use it.

@CaNsA :astonished: yes sir

You can’t install that firmware package because some of the files already exist in the firmware package (wireless-firmware-osmc) that is provided with OSMC.

Installing firmware won’t help you though if there is not a driver for the adaptor compiled for the kernel.

@ActionA so ill have to wait then mate is it ive put in a feature request for this so guess ill hve to wait thanks anyway :smile:

Please stop tagging me when someone else is attempting to assist you!

who else is trying to assist me only you and that cansa didn’t help one bit

Please advise if you are legitimately blind. If you are actually blind then I won’t consider you to be completely clueless…

Steady on chaps.

@aberboy77: it needs to be added by us. It’s on my list and I’ll have a crack at it soon


yes I am partially blind thanks a lot friend