TuneIn add-on can't connect on port 8000


I have installed TuneIn add-on on Raspberry Pi2 and I have problem playing some of the streams. I have tried to add own stream with address, but it wasn’t able to add it or start it.
I have checked the kodi.log file and here is the error from it:
16:19:33 74977.203125 T:1957757488 ERROR: CCurlFile::Stat - Failed: Timeout was reached(28) for 16:19:53 74997.320312 T:1957757488 ERROR: Previous line repeats 1 times. 16:19:53 74997.320312 T:1957757488 ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28) 16:19:53 74997.320312 T:1957757488 ERROR: CCurlFile::Open failed with code 0 for 16:19:53 74997.328125 T:1957757488 ERROR: Open - failed to open source <> 16:19:53 74997.328125 T:1957757488 ERROR: Init: Error opening file 16:19:53 74997.328125 T:1957757488 ERROR: CAudioDecoder: Unable to Init Codec while loading file 16:19:53 74997.328125 T:1957757488 WARNING: PAPlayer::QueueNextFileEx - Failed to create the decoder 16:19:53 74997.328125 T:1957757488 ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.audio.tuneinradio/?path=custom-url]

I can open the connection on my laptop without any issues, but on the Raspberry, I can’t connect to streams which are on port 8000. When the stream is on standard port 80, it opens without any issue.

Can you please help me, what could cause this kind of issue?

Firewall should be turned off:
root@malina:/home/osmc/.kodi/temp# iptables --list
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


What happens if you do wget
I just tried it on my OSMC and all works well

osmc@osmc.hongkong:~$ wget
–2015-11-28 10:50:21--
Connecting to… connected.
HTTP request sent, awaiting response… 200 OK
Length: unspecified [audio/mpeg]
Saving to: ‘96.mp3’

Sorry, I’ve forgot to mention this one.
I’ve tried also wget, but it can’t connect either. I’ve tried wget from my synology station and that’s working without any problems, so the internet connection is OK, just the Raspberry is obviously blocking this outgoing port for some reason.

osmc@malina:~$ wget converted '' (ANSI_X3.4-1968) -> '' (UTF-8) --2015-11-28 10:40:18-- Connecting to ^C osmc@malina:~$ sudo su - root@malina:~# wget converted '' (ANSI_X3.4-1968) -> '' (UTF-8) --2015-11-28 10:40:39-- Connecting to failed: Connection timed out. Retrying. --2015-11-28 10:42:47-- (try: 2) Connecting to

Ok, you must have installed something on OSMC. Normally no outgoing ports are blocked.

It was a clean install of latest OSMC image for Raspberry Pi and I’ve installed couple add-on, that’s all. Add-ons which I’ve installed are - Youtube, TuneIn, Music Video Jukebox, Pandora, PicasaWeb, RadioTunes, Sky.fm, UK Music Video Jukebox and SuperRepo for Isengard.

That’s all. I don’t think some add-on could be causing this.

Well I only can tell you OSMC doesn’t block outgoing ports.
So have you tried other downloads e.g.:
wget http://ipv4.download.thinkbroadband.com:8080/5MB.zip
wget http://ipv4.download.thinkbroadband.com:81/5MB.zip

I’ve tried it now - port 8080 works, file downloaded in 4s.
Port 81 doesn’t work from OSMC, but works from my laptop.

Really strange behaviour :frowning:

Agree, strange behaviour and not caused by any standard config on OSMC

I’ve reinstalled complete OSMC and clean install with latest updates is doing the same. Port 8080 is working, port 8000 is not working. I’m really clueless here :frowning:

fzinkens two download links work fine for me on OSMC.

As already stated, OSMC does not have any sort of firewall enabled by default,so you’ll need to look elsewhere for the source of trouble, such as your router or ISP.