TV Channels Missing From TVheadend (UK)

I have a Hauppauge WinTV-dualHD tuner connected to a Raspberry Pi B3+ with OSMC and TVheadend installed. Out of the 9 pre-defined muxes, three failed to scan. I’ve tried adding one I found on this webpage Caldbeck (Cumbria, England) Full Freeview transmitter | free and easy but that failed to scan too. All of the channels are available when I plug the same aerial into my TV. The couple of channels I’ve checked on the TV have signal strength 98% and quality 100%.

Here’s a mux I added from the page I linked. That frequency is listed there twice (as DVB-T and DVB-T2), I’ve tried both and they both failed.

I’m hoping there’s some really obvious thing I’ve missed that someone here can tell me about! :smiley:

As a general rule the predefined muxes in TVH will be out of date.

However, 9 muxes would be more than I would expect from a single transmitter. I think average is 6 or 7. Are you sure you are not picking up multiple transmitters (and therefore duplicate channels/services)?

TVH will learn muxes from the same transmitter but only if they are DVB-T format. For DVB-T2 (i.e. the HD channels) muxes you have to put them in manually.

For either I only set the below settings when creating a new mux:

  • Delivery System - DVB-T or DVB-T2
  • Freq - as X
  • Bandwidth = 8Mhz

I leave the rest of the settings as Auto / default value.

So when I set up TVH from new I create a single DVB-T using the mux details for BBC 1, BBC 2 etc. This will then find all the other DVB-T muxes. Then I add the 2 or 3 DVB-T2 muxes manually.

Thanks so much, that worked! I deleted all of the muxes except the one with BBC1 and it found a few more then I added some more with only the information you suggested (I was previously trying to fill in as many fields as I could). Now I have all the same channels that are available on my TV. :+1:

Not in all situations. Sometimes the channel info put out is not specific to your best (closest) transmitter. eg I receive from Dover but the channel info in the stream is for (IIRC) Bluebell Hill.