TV not detecting RPi 3 HDMI output at power on

I’ve just done a clean install of OSMC/Kodi 18.5 to a new SD card. On my previous build with a much older version of OSMC and Kodi 17.4, at power on of both the TV and Pi, simultanesouly, the TV would switch automatically to the Pi - its the only source on the TV.

With the new build at power on the TV doesn’t see the HDMI signal from the Pi unless I power cycle the Pi after the TV is on.

The latest version was created with the OSMC installer on Windows, whereas the original version was created by NOOBS.

There is a difference in the config.txt files and I wonder if this is the cause… would it be due to the line with ‘hdmi_force_hotplug=1’

Noobs created this…

gpu_mem_1024=256
hdmi_ignore_cec_init=1
disable_overscan=1
start_x=1
dtoverlay=lirc-rpi
disable_splash=1

NOOBS Auto-generated Settings:

hdmi_force_hotplug=1
gpu_mem_256=112
sdtv_aspect=1
dtparam=gpio_in_pin=18
gpu_mem_512=144
dtparam=gpio_out_pin=17
sdtv_mode=2
arm_freq=1200
core_freq=400
sdram_freq=400

Whereas the OSMC installer created this…

gpu_mem_1024=256
hdmi_ignore_cec_init=1
disable_overscan=1
start_x=1
disable_splash=1
gpu_mem_256=112
gpu_mem_512=144
sdtv_aspect=1
arm_freq=1200
core_freq=400
sdram_freq=400

Any help would be much appreciated.

Thanks

Did you enable that option in OSMC CEC settings?

Well if you believe that you could just add it to config.txt

I don’t think this was created by the installer

Those three lines were created by going to the overclock section of MyOSMC and it triggers a bug which modifies config.txt even when you don’t tell it to. The clock settings are also wrong so they should be removed.

If your not leaving your RPi on all the time and you find this behavior desirable you can add that line to OSMC’s config.txt.

The three clock lines probably resulted from me nosing around the overclock section but I didn’t change anything so what’s wrong with them?

So, if I add the line ‘hdmi_force_hotplug=1’, will this mean that my TV will detect the PI HDMI output when they are powered on at the same time?

That is the bug, that it modified the file without you telling it to. What is wrong with them is that they are not correct for some models of the Pi so if you put that in a 3b+ it slows it down and if you put in in a 2b it won’t boot. If you remove the lines it will use the correct settings automatically.

Maybe. I would try it and see. Your not going to hurt anything by adding that line. What it does according to the RPi foundation docs…

Setting hdmi_force_hotplug to 1 pretends that the HDMI hotplug signal is asserted, so it appears that a HDMI display is attached. In other words, HDMI output mode will be used, even if no HDMI monitor is detected.

Thanks for you help.

Adding the hdmi_force_hotplug=1 to the config.txt now means the TV switches to the Pi when they’re both powered on.

However, the aspect ratio was not correct, presumably as a result of the ‘sdtv_aspect=1’ statement.
Removing this and then going into the settings to set the correct aspect ratio fixed that.

Thanks again.

You fixed the display output to your TV by disabling the hdmi hotplug detect which make me think you are using hdmi. But now you are saying that you had to modify the behavior of the composite output (that is what the sdtv_aspect affects)? I find this doubtful. I think it is much more likely that for whatever reason your Pi just picked up the wrong display mode of your TV during boot and Kodi just rolled with that until you changed it in Kodi’s settings. There are options for forcing the hdmi boot resolution if needed.

I’m glad you got it going in any event.

Yes, your right and unfortunately I think I did both things at the same time so it probably was just the hotplug statement that seemingly fixed it.

I say seemingly because this morning the resolution was incorrect again starting up in a 4:3 aspect ratio. Going into the display settings in Kodi showed the resolution setting as blank, so I set it to 1920x1080. It seemed to go into an even higher resolution at first but then after a reboot it came out correct.

I notice that there are two other HDMI settings ‘Group’ and 'Mode. It would appear that if I set ‘Group’ to 2 and ‘Mode’ to 82, this may force the resolution to be what I need

But I never needed to do any of this on the earlier build.

I would actually recommend group 1 (CEA) and mode 16 (1080p 60hz). You can actually change this in the My OSMC add-on if you wish.

I think something changed as well with a recent update. I’m not sure what. I’ve seen this behavior on my LG TV but my Toshiba’s have been unaffected. If your using the adjust refresh rate option it should correct itself the first time you play a video as well.

This morning the system started correctly so I’lll leave things as they are for now.

Co-incedently I have an LG TV.

A quick search revealed others having similar problems - loss of resolution - but with other devices.