TV Remote no longer works properly

Recently I have been using my TV remote (Samsung) to control my Vero 4k+ and everything worked great, after the October update, it appears the Vero goes to sleep and my TV remote cannot wake it up, only the proper Vero remote can. The screen is goes completely black (not a faint image) after I finish watching something (it naturally ends or I press stop). Any button on the vero remote wakes it up, but no button on my TV remote does anything.
Even if you ignore the fact I am using my TV remote, the previous versions never went to a black screen after ending a video, they just went to the last screen I was on before pressing play.
I don’t have the logs to hand as I am at work, but I can post these tonight. Has anyone else come across this black screen since the October update?

Even when a previous version went to sleep it was just a faded image, not completely black like I am experiencing now. Has there been a new setting related to this?

Can’t think of any changes that would cause this.

Some logs will definitely help.

I got home and was about to grab the logs and it showed there was another update. I did this and did some brief testing and it seems ok now. I see how it goes when i watch something proper later

This happened again today. The log is 11MB so i couldnt use the uploader but i have grabbed it and uploaded it to TinyUpload.com - best file hosting solution, with no limits, totaly free as i didnt know how else to share.
The screen goes completely black as mentioned before. I also noticed that if i am watching a TV show the popup to ask to auto play the next episode doesnt come up when this is happening.
This happens if i leave the device at the main menu for about 5 mins or so.

Try turn everything off at the mains for a few minutes

Sam

Tried that, this evening I had it unplugged for a couple hours but it’s now worse.
During playback it now goes black screen but the video continues playing and sound still plays so seems video related. I have to push a button on the Vero remote to bring back video. This happens around every 5 mins. Every minute or so the screen flickers too.
Of course I didn’t have logging enabled when this happened as I didn’t want the log overlay displayed in the corner.
Do you have any other ideas from the log I provided yesterday?

Please fix this error:

2020-11-01 21:04:45.300 T:3938103520 ERROR: CCurlFile::Stat - Failed: HTTP response code said error(22) for http://192.168.1.2:32400/library/parts/22020/1574533138/

Then your logs will be smaller and more easy to read.
This constant log spam makes it really hard to read your logs

Cheers

Sam

Adjust display refresh rate: Off
GUI Resolution: 720x480 @ 59.94p

Ummm, doesn’t your picture look really terrible? Try setting the UI to 1080p60, enable refresh rate switching to “on start/stop” and test. If it does it again try a different hdmi cable. If that does not change anything you might try enabling HPD lock in the display settings.

I’ve done what you say in regards to enabling the refresh rate switching.
Yes it looks terrible, but that is the only resolution that doesnt have an annoying blue bar down the left hand side like the osmc “window” doesnt fit the screen properly.

@sam_nazarko i think that error was caused by plexkodiconnect syncing my music library using addon paths which doesnt affect things does clog up the log so i have stopped sycning the music library to try and clear the log.

After it got worse tonight i noticed there was a login screen behind osmc, i think this was from when i installed X11 with web browser. the only way i could remove that was to run sudo apt autoremove which seems to have solved my issue.

This sounds like an overscan issue on your TV.

Just realised that after posting and have now sorted it

Just to clarify, everything is sorted now and your original issue was solved by removing x11 and you can run in full HD now that you’ve disabled overscan on your display. So we can mark this as solved?

Yes it appears to be fixed. As it only started affecting my system after the October update it appears x11 was the issue.
This can be marked as solved

1 Like