[Tvheadend] A lot of continuity errors


I am experiencing a great amount of continuity errors with Tvheadend on my newly purchased Vero 4K+, with the original DVB-T2 TV dongle. This can be seen as artifacts while playing a TV channel.

Shortly after reboot there are no errors, but after about half an hour they begin to accumulate more and more. Both SD and HD channels are affected. Tvheadend is installed from OSMC App store, Tvheadend HTSP Client is used as a PVR client.

Tvheadend logs obtained with journalctl -u tvheadend:


Kodi logs are quite huge (54 MB) and Kodi failed to upload them, manual copying/pasting also fails. So I pasted only some portion of the log from the moment when the first continuity error appears:




Do you mean the OSMC dongle?
Have you used it on another device with success before?


Yes, exactly.

No, I have a desktop PC with Debian Stretch installed, and it will be some effort to move it closer to the TV cable, and there is also a MacBook, but I doubt if macOS is a good choice for testing. If it is important to know how the dongle behaves on another device, I’ll give it a try.

Is there any useful information in the logs?

I’ll check them shortly. Do you have an internal or external aerial? Usually discontinuities are indicative of poor reception

Are recordings affected?

External. The signal strength is around 55 dBm, SNR 40 dB.

I’ve heard that continuity errors may be caused by poor performance of the TV tuner and problems with USB throughput.

Yes, the same artifacts in recordings.


Shouldn’t be an issue on 4K / 4K +
Try the other USB port.

Any other USB devices in use?

Can you run:

dmesg | paste-log after the next occurence?


I’ve tried, the same.

Only the Bluetooth dongle, unplugging it changes nothing.


I’ve noticed one more thing: in the beginning the signal strength is at about 80 dBm, but just before the first continuity error it suddenly drops to 45 dBm. The same with SNR, which jumps from 20 dB to 35-40 dB.

Okay — one last thing to check (with SD channels); does disabling hardware acceleration help?

No, it doesn’t.

Ok — do we know if it works on your PC?
Can you also show me the TVH mux details for your location (Poland?) here.


I’ve tried it on my PC, but unfortunately Tvheadend failed to scan muxes, no idea why. And it detected only the Realtek adapter, no Sony one.

I have three muxes configured: 490 MHz, 506 MHz and 706 MHz. All other settings are auto.

Signal strength shouldn’t jump around that much. Check your aerial cabling.

I’ve no idea whether it does anything but I always check ‘low noise amplifier’ in settings for the tuner.

1 Like

Maybe, but the signal starts dropping/jumping just 25-30 minutes after reboot, so it is rather related to the device, not cable or aerial. And when plugged directly into the TV set (with built-in tuner), there are no problems.

All sticks are less sensitive than TV tuners in my experience (I have three, of different makes). FWIW, these are the values I’m getting right now with no problems.

Well, I have similar values, and right at these values continuity errors begin. Do you have the OSMC stick?

I believe @grahamh has both models.

My OSMC stick has Sony and Realtek adapters, so it must be another model. Nevertheless, the errors occur on both adapters.

Do you have any thoughts why the errors may begin 25-30 after restart each time?

Not off the top of my head.
Is there a way to recover? Does removing the dongle and re-inserting it fix the problem? Does restarting TVHeadend help etc?

Only rebooting the device.

Removing the dongle causes the Vero 4K+ to hang, so I even can’t log in via SSH. Only hard reboot helps after that.

Restarting Tvheadend as well as Kodi doesn’t help.