Tvheadend audio issue

Hi. Every so often when I turn on a channel, the stream plays but without audio. Changing to a different channel then back again often fixes it. Sometimes I need to cycle though a few channels/ change mux to fix it. Very occasionally I only get audio and no video, but this is rare. I’m seeing some continuity counter errors (H264/aac) in tvheadend logs. I believe this was an issue before updating to kodi 19, and that the issue may be limited to hd channels, but can’t be sure.

My setup seems pretty basic…two osmc dvb tuners plugged into powered usb hub. Tuners and playback on same machine. I can provide logs next time it happens but not sure how to capture tvheadend logs. Thanks.

Hard to say without logs. I’m not sure TVHeadend logs would be necessary yet.

Ok, thanks, will try and send standard logs later today. I’ve been doing a bit more testing…out of curiosity, should osmc tv tuners display signal quality reasonably accurately using tvheadend? Although I haven’t checked regularly over the last few years, I can’t ever recall seeing any healthy signal quality readings in tvheadend or player process info screen, even in properties where I’ve had no live tv issues. I’m asking because my signal quality reading in player process info for all channels is 0%. I do have an issue tuning in 1 mux, but all channels play fine otherwise, other than the fairly frequent audio dropout when initially switching to an hd channel.

Signal quality readings are of limited use and differ between DVB sticks. There’s a setting in TVH, something like ‘use old signal strength …’ which can mean the difference between seeing these values or not.

In my experience, poor signal quality is evidenced by macro-blocking of video. Never had a problem with audio.

Thanks Graham. ‘Force old status’ was already enabled. I tried deselecting it and still had readings of 0%. However, I bypassed the Vero and plugged the aerial directly into my tv and signal strength is really healthy on all channels except for the mux I can’t receive - I’ve since had a tv aerial guy look at the setup and that one mux is the result of a problem with the ‘antique’ aerial I have, so that’s ok, and he agreed that signal quality for everything else is fine.

Just skipped through a few channels and the last channel I select (BBC One HD) is missing audio. Here are logs attached https://paste.osmc.tv/asicagukif

Thanks

You have a plugin called seren. Can you try disabling that?

Just disabled it, enabled logging and rebooted. Flicked through a few channels - including BBC One HD - all fine. Last channel I switched back to was BBC One HD - video played fine but without audio.

https://paste.osmc.tv/lorizitase

Noticed the ‘cable is bad?’ warning in logs and realised only one tv tuner was showing up in tvheadend…maybe an issue with one of the usb ports on the powered hub the tv dongles are plugged in to. Swapped them out and both recognised again. This wasn’t an issue until now - a result of me swapping stuff about in order to test signal strength through my tv.

Edit: while swapping stuff about I also decided to power harmony hub from same powered usb hub…bad idea. Removed and tested channels again and so far looks good (seren still disabled). Will keep testing tmrw. Interested to know what you were seeing with seren…

I just saw it doing something in the logs. I’ve no idea what it is or what it does, but it’s always worth disabling add-ons to check.

A quick update…I ended up getting under the floorboards in my rented accommodation and finding my tv aerial cable was in fact two cables - the copper wire from each had been twisted together by hand - rusted and uninsulated. This obviously had a big part to play with intermittent buffering I’ve been experiencing for a while now. Fitted new cable and have a consistent, stable viewing experience now :grin:

Before discovering this cable butchery, I was experimenting using a rpi4 as a tvheadend server streaming to vero (and have stuck with this setup for now) - still had occasional audio drops out when changing channels, but it always recovered after 5-10 seconds. Still experience same behaviour with the new cable fitted (although less frequent) but as it always recovers now - and generally much quicker- it’s no longer an issue.

Quick question- currently running tvheadend 4.3 on the pi (built from source) to accommodate better artwork options from schedules direct. I’ve found it to be extremely stable. Are there instruction to build from source on vero? Thanks.

1 Like

I’m glad to hear that you’ve got this solved. Signal can be very important. Before the switchover I tried using an old aerial for DVB-T and this led to constant pixellation. After the switchover, I had more luck, but HD channels became problematic later on. Eunice may have been the last nail in the coffin for this aerial.

They should be the same – if you built on OSMC on Pi (as the userland is the same).

My understanding is that TVH 4.3 is still in beta and development seems to have somewhat slowed. Once it’s stable, I’ll obviously make it available as standard.

If you need help compiling it, I’m happy to advise

Cheers

Sam

Hehe, cheers Sam. Sorry I forgot to mention, I compiled tvheadend from source on a rpi running raspberry os bullseye. I’m guessing this won’t work for vero? If so, advice on compiling would be really appreciated, thanks.

I only tried compiling the ‘unstable’ version because there are better SD artwork options for 4.3+, but I did notice that their devs actually recommend installing it over stable now. Anyway, pleased to hear it’ll be available on vero when stable - I’m pleased with its performance as it’s been solid as a rock for a number of weeks since installing.

I haven’t tested, but don’t imagine requirements have changed in TVH 4.3 that much. So you could probably get away with:

sudo apt-get install git
git clone https://github.com/osmc/osmc
cd osmc/package/tvheadend-app-osmc

Edit ‘build.sh’ (nano build.sh) and change VERSION=… to an appropriate version.

Run make armv7

Then to install sudo dpkg -i armv7-tvheadend-app-osmc.deb and apt-get -f install if you haven’t had TVHeadend installed on this device before.

Thank you!

IIRC odd numbered dot versions are always ‘beta’. 4.4 would be the release.

I couldn’t get your method to work Sam. With my very limited knowledge, I’m guessing this is because tvheadend doesn’t provide any current arm packages on github, which is why I had to follow these instructions when installing on raspberry os…

sudo apt-get install git build-essential debhelper pkg-config fakeroot libavahi-client-dev libssl-dev libcurl4-gnutls-dev liburiparser-dev cmake libpcre3-dev libdvbcsa-dev libpcre2-dev

git clone https://github.com/tvheadend/tvheadend.git build/tvheadend/master

cd build/tvheadend/master

AUTOBUILD_CONFIGURE_EXTRA=–disable-libvpx\ --disable-libvpx_static\ --enable-libav\ --enable-libfdkaac\ --enable-hdhomerun_client\ --enable-ffmpeg_static\ --disable-bintray_cache ./Autobuild.sh

…then depackage the resulting armhf.deb file produced (from memory, I think this was a ‘binary-only’ upload, whatever that means). Out of curiosity, I tried this method on vero - it set itself away but ultimately failed to build.

If there’s anything obvious that will make this work then please let me know, but as I plan to move tvheadend server over to a nas I’ll be purchasing later in the year, and have a working setup with rpi as a server, this is not important. i.e. don’t waste your time if it’s a more complicated process. Thanks.

What was the error?
Did you try my instructions?

Using your instructions, I’m not sure how the tvheadend version number should be represented in nano build.sh. I tried the following…

VERSION=“V4.3” - spends a minute or two building then…

Package installed successfully
/mnt/package/tvheadend-app-osmc/src/tvheadend-4.3 /mnt/package/tvheadend-app-osmc
Applying patch all-001-do-not-use-git-for-muxlist.patch
patching file support/getmuxlist
Hunk #1 FAILED at 8.
1 out of 1 hunk FAILED – saving rejects to file support/getmuxlist.rej
Exiting build with return code 1
make: *** [Makefile:8: armv7] Error 1
make: Leaving directory ‘/mnt/package/tvheadend-app-osmc’
make: *** [Makefile:8: armv7] Error 2

Also tried specific version numbers (which I now realise was never going to work)…
VERSION=“tvheadend_4.3-1994~gc7b713edb” /
VERSION=“V4.3-1994~gc7b713edb”

which leads to…
Downloading tarball failed
make: *** [Makefile:8: armv7] Error 1

The error I get via building through the instructions I found:

make[1]: Leaving directory ‘/home/osmc/build/tvheadend/master’
debian/rules override_dh_auto_build
make[1]: Entering directory ‘/home/osmc/build/tvheadend/master’
make
make[2]: Entering directory ‘/home/osmc/build/tvheadend/master’
make -f Makefile.ffmpeg libcacheget
make[3]: Entering directory ‘/home/osmc/build/tvheadend/master’
make[3]: Leaving directory ‘/home/osmc/build/tvheadend/master’
make -f Makefile.ffmpeg build
make[3]: Entering directory ‘/home/osmc/build/tvheadend/master’
WGET https://ftp.osuosl.org/pub/xiph/releases/ogg/libogg-1.3.4.tar.gz
GnuTLS: The TLS connection was non-properly terminated.
Unable to establish SSL connection.
make[3]: *** [Makefile.ffmpeg:366: /home/osmc/build/tvheadend/master/build.linux/ffmpeg/libogg-1.3.4/.tvh_download] Error 4
make[3]: Leaving directory ‘/home/osmc/build/tvheadend/master’
make[2]: *** [Makefile:853: /home/osmc/build/tvheadend/master/build.linux/ffmpeg/build/ffmpeg/lib/libavcodec.a] Error 2
make[2]: Leaving directory ‘/home/osmc/build/tvheadend/master’
make[1]: *** [debian/rules:15: override_dh_auto_build] Error 2
make[1]: Leaving directory ‘/home/osmc/build/tvheadend/master’
make: *** [debian/rules:6: build] Error 2
dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2

I’ve learnt a lot of linux basics through support on this forum, but you’re dealing with a novice here, so happy to leave things unless there’s something really obvious I’m doing wrong. Thanks.

You could do rm patches/all-001-do-not-use-git-for-muxlist.patch before building.

Cheers Sam, appreciate your willingness to help. Did as you suggested but there are more errors…copied a chunk of the logs:

After this operation, 3612 kB of additional disk space will be used.
Get:1 Index of /debian buster/main armhf libpcre2-8-0 armhf 10.32-5 [190 kB]
Get:2 Index of /debian buster/main armhf wget armhf 1.20.1-1.1 [881 kB]
Fetched 1071 kB in 0s (2963 kB/s)
debconf: delaying package configuration, since apt-utils is not installed
E: Can not write log (Is /dev/pts mounted?) - posix_openpt (19: No such device)
Selecting previously unselected package libpcre2-8-0:armhf.
(Reading database … 13878 files and directories currently installed.)
Preparing to unpack …/libpcre2-8-0_10.32-5_armhf.deb …
Unpacking libpcre2-8-0:armhf (10.32-5) …
Selecting previously unselected package wget.
Preparing to unpack …/wget_1.20.1-1.1_armhf.deb …
Unpacking wget (1.20.1-1.1) …
Setting up libpcre2-8-0:armhf (10.32-5) …
Setting up wget (1.20.1-1.1) …
Processing triggers for libc-bin (2.28-10) …
Package installed successfully
Package libdvbcsa-dev is not found on the system, checking APT
Found in APT and will install
Installing package libdvbcsa-dev…
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following additional packages will be installed:
libdvbcsa1
The following NEW packages will be installed:
libdvbcsa-dev libdvbcsa1
0 upgraded, 2 newly installed, 0 to remove and 22 not upgraded.
Need to get 27.2 kB of archives.
After this operation, 87.0 kB of additional disk space will be used.
Get:1 Index of /debian buster/main armhf libdvbcsa1 armhf 1.1.0-2+b12 [23.7 kB]
Get:2 Index of /debian buster/main armhf libdvbcsa-dev armhf 1.1.0-2+b12 [3528 B]
Fetched 27.2 kB in 0s (166 kB/s)
debconf: delaying package configuration, since apt-utils is not installed
E: Can not write log (Is /dev/pts mounted?) - posix_openpt (19: No such device)
Selecting previously unselected package libdvbcsa1:armhf.
(Reading database … 13936 files and directories currently installed.)
Preparing to unpack …/libdvbcsa1_1.1.0-2+b12_armhf.deb …
Unpacking libdvbcsa1:armhf (1.1.0-2+b12) …
Selecting previously unselected package libdvbcsa-dev:armhf.
Preparing to unpack …/libdvbcsa-dev_1.1.0-2+b12_armhf.deb …
Unpacking libdvbcsa-dev:armhf (1.1.0-2+b12) …
Setting up libdvbcsa1:armhf (1.1.0-2+b12) …
Setting up libdvbcsa-dev:armhf (1.1.0-2+b12) …
Processing triggers for libc-bin (2.28-10) …
Package installed successfully
/mnt/package/tvheadend-app-osmc/src/tvheadend-4.3 /mnt/package/tvheadend-app-osmc
Applying patch all-002-use-legacy-DVB-api-for-AMLogic-3.14-kernel.patch
patching file src/input/mpegts/linuxdvb/linuxdvb_frontend.c
Hunk #2 succeeded at 813 (offset -37 lines).
Checking support/features
checking for cc execinfo.h … ok
checking for cc -mmmx … fail
checking for cc -msse2 … fail
checking for cc -Wunused-result … ok
checking for cc getloadavg … ok
checking for cc atomic64 … ok
checking for cc atomic_time_t … ok
checking for cc bitops64 … ok
checking for cc lockowner … ok
checking for cc qsort_r … ok
checking for cc stime … ok
checking for cc gmtoff … ok
checking for cc recvmmsg … ok
checking for cc sendmmsg … ok
checking for cc libiconv … fail
checking for cc libdvben50221 … fail
checking for cc ifnames … ok
checking for cc llabs … ok
checking for py module gzip … fail
checking for pkg-config … ok
checking for xgettext … ok
checking for msgmerge … ok
checking for gzip … ok
checking for bzip2 … ok
checking for pkg openssl … ok (detected 1.1.1d)
checking for cc linux/dvb/version.h … ok
checking for cc libhdhomerun/hdhomerun.h … ok
checking for pkg zlib … ok (detected 1.2.11)
checking for pkg liburiparser … ok (detected 0.9.1)
checking for pkg avahi-client … ok (detected 0.7)
checking for pkg libavfilter >=6.31.100 … fail (detected )
checking for pkg libswresample >=2.0.101 … fail (detected )
checking for pkg libavresample >=3.0.0 … fail (detected )
checking for pkg libswscale >=4.0.100 … fail (detected )
checking for pkg libavformat >=57.25.100 … fail (detected )
checking for pkg libavcodec >=57.24.102 … fail (detected )
checking for pkg libavutil >=55.17.103 … fail (detected )
WARNING: none or old ffmpeg libraries were detected
* use --disable-libav or --enable-ffmpeg_static
checking for cc dvbcsa/dvbcsa.h … ok
checking for cc -ldvbcsa … ok
fetching dvb-scan files … fail
checking for git … fail
FATAL: git binary not found (install the git package)
ERROR: Failed to fetch dvb-scan data (use --disable-dvbscan)
Makefile:666: /support/.mk: No such file or directory
make: *** No rule to make target ‘/support/.mk’. Stop.
Makefile:666: /support/.mk: No such file or directory
make: *** No rule to make target ‘/support/.mk’. Stop.
Error occured during build
make: *** [Makefile:8: armv7] Error 1
make: Leaving directory ‘/mnt/package/tvheadend-app-osmc’
make: *** [Makefile:8: armv7] Error 2