TVHeadend client not connecting


I am a using OSMC for the first time. I am a long-time Linux user, though. My setup is:

  • Raspberry Pi 3 Model B+
  • OSMC 2018.03-2, Kodi 17.6
  • Installed TVHeadend (4.2.4) and Cron from the App Store
  • USB TV Tuner - Omega T900 DVB-T, based on IT9135, supported out-of-the-box
  • Installed a bunch of other packages I would need via ssh but none of them is really ‘running’ - e.g. python3, build-essential (for pip3 installs), etc. Note that I’ve had the same problem even before installing extra packages (on a previous install of OSMC)
  • This is, apart from the installed packages, a clean install. I’ve already reinstalled OSMC a couple of times before this, as I tested/broke it.

On to the issue I am facing:

I have installed TVHeadend and set it up correctly, using the adapter listed above. Channels are listed properly, with EPG. However, whenever I try to start a channel, I get a “Buffering…” message, and then an error “TVHeadend HTSP Client - no connection” (or something like it, I’m not using it in English), and nothing happens. Only very, very rarely, a channel would play a frame or two and freeze.

I have tested connecting to the same TVHeadend server from Kodi on a desktop computer (Linux XUbuntu 17.04) and all works fine - I can watch all channels and they start almost immediately after hitting ENTER on them. I have also tried running the TV streams in VLC directly from the TVHeadend web UI in a browser (same LInux computer) and it all works - actually I played 3 channels simultaneously (from the same MUX) in VLC and they work without a hitch. Watching with htop via ssh shows the CPU cores are all below 20% and memory is not even half-full in this case.

Here are the uploaded logs, as required when posting an issue. These logs were uploaded from “My OSMC”, after a restart of OSMC and testing of playing two channels. After uploading the logs I immediately tested playing several channels on the desktop computer and they played fine.

What is going on? Why can’t only the Pi’s Kodi play any channel? Please help me find out the reason and fix this.

How did you configure the HTSP Client in Kodi?

What is the codec and resolution of the Streams? Can you record one stream and play it on the Pi?

It uses the default settings -, default ports 9981 and 9982, empty user and password, but I’ve also tested with osmc for user and password, with the same result.

The same settings are used on the desktop computer. Well, apart from the IP, of course.

Ok, that should be fine. Check my second question

I’m not sure I understand your question. I’ll try to answer but if I’m completely wrong please correct me and tell me how to do what you ask.

The streams are coming from the DVB-T adapter. They are standard, I think only one is HD (it has HD in the name of the channel). In the streaming settings in TVHeadend, where I can choose htsp, matroska and pass, I’ve tested making each of them Default, with the same result. The last one I used when the log was generated was pass, or so I think.

As for recording a stream and playing it on the Pi - how do I do that?

Pass means the original stream is passed through. So you would need to figure out what Codec is used (most likely H.264).

You can do that via the HTSP Client in Kodi AFAIK

Where can i see this? Also, I’ve just noticed in TVHeadend web UI - > Status - > Subscriptions, it says Kodi Media Center and then for “Profile” it lists htsp. This is while trying to play a channel on the RPi. Why, if I’ve set the pass as a default?

I made a recording from the TVheadend web UI, and then played it on the RPi (had to change to skin to Estuary to find the recordings section). The recording instantly starts playing and runs fine. Then tried to play the same channel I did the recording on - doesn’t play.

[EDIT] Damn it, I tried setting the default to be htsp for a test, and after a restart of the RPi, all the streaming profiles are gone and I can’t play anything even from the web UI!!! And trying to create a profile just doesn’t do anything. Any chance of getting them back?

All the settings are in ~/.hts. But in your situation, I think I would start again. Wipe ~/.hts, uninstall/reinstall TVH and go through the TVH wizard selecting as many defaults as possible to get it going, then play with other options if you have special requirements.

I removed only the files in ~./hts/tvheadend/profiles and restarted the tvheadend service, and the profiles appeared again in the web UI.

After that I managed to fix it, as it seems. In the settings of the TVHeadend Client in Kodi, section “Streaming”, into the profile (where it was previously empty = default) I entered htsp. And magically, the TV channels started playing. I’ve also tested entering pass and matroska there, but for both Kodi says that they’re “not available” after saving the settings. What’s going on? Am I missing a package installation?

I’m glad the issue has been resolved but I am curious why it solved the way it did?

I don’t know. If TVH finds any bits missing from its settings it fills them in with the defaults. My HTS client is set to default and my pass settings are like this:

That is all as the default installation so should be the same as yours. This is on Vero but was the same on RPi before.

Yup, that’s the same setting I see here. Oh, well, it is fixed anyway. I’ll just remember what I did in case I need to do it again.

Thank you for your help!