TVHeadend Client


I have TVHeadend 4.0.8-3~gc870eb9~wheezy server running on a R-Pi 2 quad core model.

Now on two R-Pi devices running Kodi and attached to TVs I have sound co-ordination issues when viewed using the TVHeadend PVR addon client. The sound appears fine if viewed on my Android phone or Nexus device so am of the opinion it may be down to a Kodi setting or addon setting.

Appreciate the sound can be delayed but the sync appears to vary.

I’ve tried to look for the obvious but cannot see anything obvious.

Networking is via homeplugs which I think eliminates that potential problem.

Any hints would be appreciated.


Purchase and install mpeg2 codec license.

Always had that on the client but not on the server. Don’t think it is needed on the server.


I think this may be the same issue I am now having. I have a similar setup, Pi2 running tvheadend (I have the osmc apps store version, 4.0.7 I believe) and a Pi B connected to a different TV (will be 2 Pi Bs when I get my other one back). Sometimes the audio and video will start in sync but will gradually get more and more out of sync, other times it will start out of sync. This happens on both SD and HD channels.

I had no issues until recently. I have made a few changes between when I know it was working ok and now so have been trying to eliminate them one by one. The changes that I have not yet tried reverting are the update to Jarvis and a few configuration changes I made to a FreePBX installation that is also running on the Pi2 (although these were minor changes, and FreePBX has been happily running on the Pi2 without any issues for 3 months before this.)

As I posted in another thread I have also had issues with config.txt and the codec keys but that has now been resolved, yet this issue remains. Both Pis now have the codecs installed and working.

Ok. I’ve done some testing and found that the issue isn’t present in Isengard but is in Jarvis. I’ve also narrowed it down to OMXPlayer as disabling it fixes this issue. Checking the codecinfo screen in Kodi when the sync issue occurs shows an audio queue that rapidly descends into negative values as does the audio delay, I saw it get to around aq:-10000% and ad:-800.

So I guess there were some changes to OMXPlayer between Isengard and Jarvis and one of these is the culprit. Anyone got any ideas where to go from here?

I can confirm I am seeing the same issue. Sync issues between the audio and video exactly as you describe and it is down to omxplayer in Jarvis

Are the to pi’s using wireless networking? then the issue could be bad wireless coverage… i have seen that… try replicate it with ethernet.


In my case the pis use ethernet connections.

Not using WiFi - using homeplugs so effectively wired ethernet connection.


i have some home plugs as well at home, and my experience with them is not good… speed is not stable enough… could you try with ethernet?.


Purchasing an MPEG2 codec license solved the problem for me.

I have been fighting the same problem. Discovered the same cause (before finding this thread on the forum). I have the proper license and all. Changing the GPU memory settings do not impact the failure frequency. Takes only a few minutes to lock up the display. Have to ssh in to order a reboot.
I’m using the HDhomerun tuner. Worked well before jarvis.

System will work now without hardware accelleration but the CPU is doing all the work. Linux top command reports 300% utilization. I measured the CPU heatsink temperature (I installed some time ago because I do run turbo mode). Temperature is well within allowable limits.
Tom S


It streams HD video fine for prerecorded video, if there is a sync issue with precorded files I normally pause, rewind a fraction, then all fine.

LiveTV streaming has the sound sync problem only through Kodi and client.

No sound problem on mobile phone or Netpad.


Same, connecting to Tvheadend with Kodi on my laptop and tablet (Windows and Android) has no sound issues.

I need to test this further as I haven’t tested extensively, but this bug seems not to be present in the latest Krypton build. Nearly an hour watching TV and I can’t see any sync issues yet, but I’ll continue with Krypton tomorrow, see how it goes.

EDIT: Well, all seemed good with Krypton, then I installed the latest build and the issue is back. but Krypton build 16.8-046 seems OK if anyone wants to try it.

So, Isengard is fine Jarvis has the sync issue, Krypton build 16.8-046 (as far as I can tell) is fine but 16.8-047 onwards also have the sync issue. Seems to be OMXPlayer… I don’t know where to go from here. Maybe @popcornmix could make some suggestions as it’s OMX related, has anything changed with OMX that could cause this?

Logs from Krypton 16.8-048:
I’ve no idea what to look for in that.

Same problem here: Pi 3 running osmc and Tvheadend locally: sync problems!
Any solution??