TvHeadend HTSP Client Access Denied

I have just configured the TvHeadend Server on my Vero4k+ and have gone through the setup wizard.

I made it accessible by all devices on my local network through:
And set the administrator username and password to osmc, but when I configure the HTSP client it tells me “Access Denied”.

Does anyone know what I’ve done wrong?
Debug logs here

Can you log in to the TVHeadend admin page with osmc/osmc

1 Like

So, you configured the tvh htsp client to use the right user+password at settings->addon-browser->user-addons->pvr-clients->tvheadend htsp client->configure ?

1 Like

Yes @thansen_dk I can. I can view everything through the web gui logging in with those credentials. Also tested scheduling and removing a recording through the web gui and that worked as well. It’s just the HTSP client :slightly_frowning_face:

As far as I know @JimKnopf, did it a few times and still no change.

can you post the output of

cat ~/.kodi/userdata/addon_data/pvr.hts/settings.xml

Thanks @grahamh, here is the output of that

osmc@Vero4k:~$ cat ~/.kodi/userdata/addon_data/pvr.hts/settings.xml
<settings version="2">
  <setting id="autorec_approxtime" default="true">0</setting>
  <setting id="autorec_maxdiff">15</setting>
  <setting id="connect_timeout">10</setting>
  <setting id="dvr_dubdetect" default="true">0</setting>
  <setting id="dvr_ignore_duplicates">true</setting>
  <setting id="dvr_lifetime">8</setting>
  <setting id="dvr_playstatus">true</setting>
  <setting id="dvr_priority">2</setting>
  <setting id="epg_async">true</setting>
  <setting id="host" default="true"></setting>
  <setting id="htsp_port">9982</setting>
  <setting id="http_port">9981</setting>
  <setting id="pass">osmc</setting>
  <setting id="pretuner_closedelay">10</setting>
  <setting id="pretuner_enabled" default="true">false</setting>
  <setting id="response_timeout">5</setting>
  <setting id="stream_readchunksize">64</setting>
  <setting id="streaming_profile" default="true"></setting>
  <setting id="total_tuners">2</setting>
  <setting id="trace_debug" default="true">false</setting>
  <setting id="user">osmc</setting>

I can’t see anything wrong with that except, oddly, I don’t have the version=“2”, despite being on the same hts client version as you (v4.4.17). I upgraded from 3.4.27 with Leia.

Can you get in if you set the access mask to Or add to the access mask. See here in the tvh help screen:

Thanks @grahamh, I kept the username and password for the access entry the same and added to the allowed networks. So it is now:,

And it works! I’m glad that it works, but I find it odd that I needed to do it…:thinking:

If your tvheadend server is running on the same machine as the Kodi client there is nothing odd about that as your request will not go out via the LAN Interface/IP

1 Like

The server is running on the same machine as the client. I guess I mentioned it as odd as I had the exact same configuration on my Raspberry Pi2B with server and client running on the same machine before I upgraded to my Vero4k+.

In that instance I also just had set as the allowed network mask.

Glad to hear that’s working, now. Well at least the tvheadend help displays this solution as an example:

1 Like

Are you sure the client was set to and not 192.168.1.x?

1 Like

I’m not 100% sure :wink:, and the circumstances regarding this issue and how it was resolved do make me doubt my memory regarding this.

That’s really good to know. I wasn’t aware that there was information regarding this in the Tvheadend help.