Tvheadend installation from OSMC App Store and manually not working

Hello everybody,

As you will notice quickly: my English is really bad. I am totally dependent on google translate. but I hope that you understand me anyway.

I’m new here, have almost no Linux experience and try nevertheless, to help myself.

But now I’m stuck.

I’ve only tried tv headend manually install.
For this I advanced “/etc/apt/sources.list” with the entry “deb Index of /stable/ jessie main”, but then appear to the fetch of the packets and attempt to install with the error message in German:

W: bust when fetching Expected entry »main / binary-armhf / Packages" could not be found (incorrect entry in sources.list or release file malformed file).

E: Some index files failed to download. They have been ignored or old used in their place.

First I vermutele an error when adding the sources.list (for example, an invalid character).

In the installation attempt of tvheadend server 4.05 on the App Store OSMC however the following error appears to me.

OSMC Update Error:
** Error installing:**
** Please report this on the OSMC forum.**

I think the day before yesterday I managed to install from the App Store.

Now I hope for your help.
Thanks in advance.


If anyone is interested: My problem has a long history:
I’m trying to run to get tvheadend to receive in Germany via DVB-T2 broadcast HD channels. At first I used the OpenELEC Distribution. Thus ran tvheadend right away and I could even scan and HD channels for some manual configuration. But unfortunately you can these channels in the frontend not watch because the HD stream stops when Buffering 0% immediately. As I found out, this is a bug under Kodi 15.2. A stable distribution higher than version OpenELEC 6:03 with Kodi 15.2 is currently not to get.

OSMC (Kodie 16.1 RC3)
Raspberry Pi Model B 3
DVB-T USB stick August DVB-T210 (Chipset: Geniatech T230)

Ok, first I wonder why you tried to install it manually, didn’t you see the app store version?

Suggest to try following

sudo apt-get remove tvheadend
remove the repository from /etc/apt/sources.list
sudo apt-get -f install
then install from App store

Report an errors being shown.

Thank you for your quick help.

unfortunately brought suggestions from you no solution.
I have the OSMC Distribution freshly placed. There is no tvheadend on the SD Card. Therefore, nothing is found on all entries you mentioned.

First of all, I had installed the OpenELEC distribution that took tvheadend 4:08. for OpenELEC. That worked. The problem here was that in the used Kodi 15.2 a bug exists that prevents it to view HD channels via DVB-T2 (Germany only).

So I tried other distros for my rPI 3 with tvheadend - currently I am working with OSMC and Kodi 16.1. I hope, as the DVB-Bug does not exist in Kodi.

tvheadend from OSMC AppStore has the version 4.05. Yesterday I had it still can download from the App Store. However, it does not work with my DVB-T Stick - there are no channels / services found.

So I tried the manual installation. That was not possible - see error message in my first entry. When I tried installing again from the App Store, I got there an error window “” OSMC Update Error “with the error message” Error Installing. Please report … ".

My real goal is tvheadend 4.08 on my OSMC Distribution (Jessie, Kodi 16.1) to get to run.

I hope now everything is a bit more understandable.