Tvheadend - IPTV Automatic Network struggles with commas in links


when i add my local playlist via the “url” eg. file:///home/osmc/playlisttestANSI.m3u

I get errors like
iptv: invalid error code 400 for ‘rtsp://’

clearly there seem to be troubles regarding the encoding as the %2C ascii code should be interpreted as commas.

I have already tried several of the listed content encodings in the advanced settings of the therefore created network without success. :confused:
Could this somehow origin from running it on OSMC?

PS: adding the links manually works well

Maybe you need change pids=0,7290,1290,0,22…
can you say which tuner this is.

Maybe you need change pids=0,7290,1290,0,22…

you mean replacing %2C by commas?
either I got you wrong or the other way around :slight_smile:
as in the file itself the links are correct:

sry of course, it’s a SAT>IP Server - “Digital Devices Octopus NET V2 S2”

If this is sat-ip server why you dont use tvheadend sat-ip as client?

I tried to and it basically works well but it doesn’t support the CI cards/encryption.

Due to this I had to add the few encrypted channels manually to an IP network.
As they access the same source right now both networks interfere each other (epg grabbing blocks the other network or sometimes they don’t fast enough unsubscribe before the other one subscribes. An addition trouble is that I right now just can feed one tuner with a signal but can not deactivate it for the IP network, what also causes therefore “no signal” when the server tries to use the other tuner).

That’s why I want now completely switch to IP-Network as a source and limit it to one stream.

sorry i can not help you can try ffmpeg

pipe://ffmpeg -loglevel quiet -i rtsp://@,7290,1290,0,2290,1290,18,17,16 -c copy -flags +global_header -strict -2 -f mpegts pipe:1

1 Like

np, thanks for trying to :slight_smile:

for other people after last January update ffmpeg missing

sudo apt-get install ffmpeg