TVHeadend is not working at all

Hi

Just got my brand-new Vero and wanted to install TVHeadend together with my Sat>IP tuner. TVHeadend 4.2.5 was running on a Raspberry Pi 3B+ just fine but I wanted to run it on the Vero instead.

I installed it from the App store and started to set it up via the web UI (see tvh1.jpg). The Sat>IP server has been detected with it’s 4 tuners (Unicable installation). I set up the pre-defined Mux for Astra and the position (see tvh2.jpg). Well - TVHeadend found only a few services (see tvh3.jpg and tvh4.jpg). That was it - nothing else happened. It was just stuck there. I rebootet and did the setup all over again many times. Nope, didn’t work at all - always the same outcome - it did not find any services besides the eight you can see in the screenshot.

I also copied the .hts folder from my Raspberry Pi to the Vero - that worked fine, I could watch TV and change channels. Unfortunately it did not update any EPG.

What can I do to run TVHeadend properly? Do you need any specific log files or something else?

thanks in advance, regards,
Dieter

Do you use a webEPG? Maybe some binaries are missing.

Nope. I also tried a forced channel scan - nothing. Just the 8 services from the screenshot.

I read most of the other threads about TVHeadend in the forum but that did not contain any solution for me. I guess it would be a bad idea to use the data folder and configuration from the 4.2.5 version for the 4.2.6 version I find in the app store?

I’d like to install and setup a working 4.2.6 on the Vero from scratch to be honest. Any idea how to achieve that is apprechiated.

kind regards,
Dieter

sudo apt-get remove --purge armv7-tvheadend-app-osmc
rm -rf /home/osmc/.hts

Then run sudo apt-get install armv7-tvheadend-app-osmc

Sam

Hi Sam,

yes, I did exactly this. The hostname of my Vero is “James”, so I go to james:9981 with my browser.

Step 1:

I see the 4 tuners of my Sat>IP server (as you could see on my screenshot) under DVB Inputs - TV adapters.

Step 2:

I select “Networks”, I choose “Astra” as the Network name, “19.2E:Astra” as the pre-defined mux and “19.2E:Astra 1KR/1L/1M/1N” as the orbital position. I hit “Create”.

Step 3:

I select “Muxes” and see the enabled pre-defined Mux “Astra” in the list.

Step 4:

I verify that all 4 tuners and their first position are enabled and mapped to “Astra”. I go to Networks and force a scan. I go to “Services” and I see 8 services found (as can be seen in my screenshots).

That’s it. Nothing else happens, no matter what I do.

There should be hundreds of services in the list after a while, not just eight, am I right? Did I do something wrong or did I forget something? Just to make this clear, I installed and setup TVHeadend a dozen times on Raspberry Pi’s with no problems whatsoever.

Edit:

If I go to the “Networks” tab again the pre-defined mux field is always empty - I can only select 19.2:Astra then. But it is empty again after that. Is the mux definition “kaputt”?

I added screenshots so you can see how it looks right now.

Regards,
Dieter

I checked again after a while. Nope - only 1 mux and 8 services. There should be 127 muxes and 3785 services, at least.

Well, I just copied the “input” folder from my working 4.2.5 installation to the Vero. Then I started the TVHeadend service and voila’: all is working as expected. Even the EPG is working.

But this is not the way it is intended to work, right? Maybe we could find the problem together. It is somewhere in the networks or mux section. If you need additional information then just let me know.

regards,
Dieter

Hi Dieter,

for me it sounds more plausible that something special is configured with tuners in the tv-adapter menu on the Pi compared with the defaults you started with on the Vero.

Could you restart on the Vero by purging the .hts folder and then compare each item of the Pi’s tv-adapter treeview with the corresponding one you see on the Vero?

If there is a difference (different timing/flags) and this is the root cause for the failing mux scan then it is a special delta related to your sat>ip tuner. Feel free to document this in an how-to article for the community here in the forum.

Greetings from Germany.

Hi

Well, I did exactly that yesterday evening with two browser windows comparing Vero left and Pi right. In terms of technical setup they are absolutely identical. And no, there is nothing special setup in the TV adapter section.

I compared file-by-file in the input folder - all readable files are identical, the mux files are binary so I could not visually compare.

I also thought maybe some special setup for my Sat>IP tuner but nope, that’s the joy of Sat>IP - it just needs no special consideration or voodoo dancing to set it up properly.

To be honest, I am out of ideas. It is working now with the copied “input” folder from the Pi, so my lady can watch her Formular One. So I’m good for now.

But I still want to find out why it doesn’t work out-of-the-box with the Vero installation.

Ok, if the TV-adapter entries look absolute the same … what about the muxes? In case of the failing scenario … do all the displayed muxes show “Scan Status: Idle” + “Scan Result: OK” … or are there entries with a Failed scan result? Are the lists of muxes exact the same (sort for frequencies and compare the mux related entries like DVB-S/DVB-S2 etc.).

Additional: (You used the expert view mode to compare the items?)

Yes, I did use the expert view mode :slight_smile:

The displayed muxes displayed “Scan Result: OK” and no entries with failed scan results. The frequencies I have to look up again, the few I compared are identical. I will re-check on the mux related entries later today.

I’m not using DVB-S/DVB-S2 but added a DVB-S network in my configuration using the predefined orbital position from your screenshots above:

Believing the information table

https://www.satindex.de/transponderv-1.php

this frequency is not valid/accurate (anymore):

Nearest match would be frequency 12552000 … but this belongs to

I have my doubts that one should rely on this transponder will send a valid and actual NIT (network Information table), means while scanning this transponder you get a complete/correct list of all available transponders for Astra 19.2° East.

I’m sure if you choose a more reliable starting mux like for Frequenz + Infos zum Sender Das Erste auf Astra 19.2° Ost you get the expected results.

Leaves the question, who is responsible for the pre-defined DVB-S mux information within TVheadend? Will inform the other mods who could know this information.

This comes from upstream and usually falls out of sync quite frequently.

Sam

@JimKnopf

That’s the solution. The mux data is completely wrong or outdated. I choose the one from your link and voila’ - it started running, finding all the muxes and services. For me the problem is solved.

Have fun, regards,
Dieter

1 Like