TVHeadend not working after December Update


I just updated to the December release and TVHeadend doesn’t seem to be working. How do I tell what has happened to it?



To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Hi Sam

I uploaded the logs I think, I haven’t done this before, and it gave me the message

Is that all you need

Cheers Keith


Keep seeing this in the logs:

11:13:26.002 T:1350562560   ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - Command hello failed: No response received
11:13:26.002 T:1350562560   ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - failed to send hello
11:13:31.003 T:1555821312   ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - unable to connect to

Doesn’t appear to be able to connect to the Tvheadend server.

Thanks Tom.

Further down it says that accesscontrol/1 is invalid


Apologies only quickly read the log, didn’t realise the server was on this pi aswell.

Seems similar issues has occurred before with an update:

I would check the tvheadend config file.

Thanks Tom.

As suggested by Tom I fixed it by deleting the file
and then rebooting.
For some reason I then had a problem connecting to SMB but another reboot after that fixed it

Thank you for your help Tom

All seems to be ok now


Glad to hear its sorted.