TVHeadend not working after upgrade

I run OSMC in headlesss mode entirely to support a TVHeadend backend server. I had noticed some stuttering in Sunday Night Football which wasn’t present at the end of last season, so I decided to upgrade OSMC to see if that might have anthing to do with it. OSMC hadn’t been upgraded in a year, and when it finished all the updates, TVH doesn’t work. The process is running but I can’t access the web interface. I tried uninstalling and reinstalling, but no change.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I have uploaded the requested log files.

It has tried to update from TVH 4.2.2 to 4.2.8 (missing out 4.2.6) so may have choked. Try this:

sudo systemctl stop tvheadend
mv ~/.hts/ ~./hts.bak
sudo systemctl start tvheadend

That will force it to create new config files and database. You will have to do the setup again.

Are you sure? The reason I ask is I entirely uninstalled TVH and then reinstalled it. Does uninstalling not clear out all the old settings?

No. I don’t think even a purge does it. Anyway, your log showed it trying to upgrade the config from 4.2.2 to 4.2.8.

I think I got it working again. Is there any way to add back in the recordings which are still there?

TVH keeps its recording ‘database’ in .hts/tvheadend/dvr/log. You could try copying that across, but in those files are hashes for channel and config_name which may have been changed.

Then, I don’t know how the TVH plug-in and Kodi itself reads and uss those files.

Worth a try, though.

Great suggestion. That more or less worked. It also copied over the upcoming recordings that had been scheduled on the old version (and thus were duplicates), but those were pretty easy to spot and manually remove.

1 Like