TVHeadend not working with Pi2 - please help

Hi,
I have installed the latest OSMC (2015.12-04) and a few versions before that. Then I went to OSMC app store and installed the TVHeadend server. Afterwards I connected to my tvheadend web interface and added all the TV channels that are available in my area.
However, when I click “Play” on any of the channels in the browser, the channel never starts playing. If I then enable TVHeadend HTSP client in the OSMC on the Pi (via Enable checkbox in Settings -> TV -> General) the OSMC reports a TVHeadend server has been found on the local address (192.168.0.107) so I connect to it.
Then I keep getting error message “TVHeadend HTSP client connection lost” forever and the Live TV option never appears in the main menu.
Has anyone seen anything like this? Is there a known fix?

Thanks!

Can anyone from the support take a look into this?

I can confirm that for Edge browser. Other browsers will just download playlist which would also many times failed to authenticate in VLC. This is especially true for 4.0.7.

“HTTP” subscribing to mux
495 ms later
“HTTP” unsubscribing…

Logs from VLC on mux streaming attempt:

http debug: protocol 'HTTP' answer code 401
http debug: Server: HTS/tvheadend
http debug: Authentication header: Basic realm="tvheadend"
core debug: Using Basic Authentication
http debug: Connection: Close
http debug: Content-Type: text/html
http debug: this frame size=193
http debug: authentication failed for realm tvheadend

"I connected to my tvheadend web interface and added all the TV channels that are available in my area. " < not good…

  1. Set up Relevant Network(s)
    Tvheadend web interface: Configuration -> DVB Inputs -> Networks
    Create a network of the appropriate type here
    The creation process allows you to select from a series of pre-defined mux lists for common DVB sources.
  2. Associate the Network with the Respective Tuner(s)
    Tvheadend web interface: Configuration -> DVB Inputs -> TV Adapters
    Associate each of your tuners with the correct network through Parameters -> Basic Settings .
    save…
    wait for “initial scan” … or in network click for “force scan” .

    https://tvheadend.readthedocs.org/en/stable/configure_tvheadend/

To get a better understanding of the problem you are experiencing we need more information from you. MOST IMPORTANTLY, you need to provide DIAGNOSTIC LOGS so we can diagnose the problem. If you don’t supply logs, we can’t help you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Hi @HarryL,
I have uploaded the log to:
http://paste.osmc.io/uwedaheyob

This is from RPi 1 where the behaviour of TVHeadend is exactly the same as with RPi 2. After installing and configuring the TVheadend I enable TV in the OSMC System->TV menu and from that moment I keep getting error message “Tvheadend HTSP Client connection lost”.
The DVB Tuner is AverMedia Volar HD and it worked well with Openelec in the past.

@charlotte I am always doing exactly what you described, I just didn’t feel it needs to be mentioned since that’s what I always do when configuring the TVheadend.

Thanks!

The replication should be very simple for anyone trying to work with OSMC and Tvheadend. Simply turn the feature on and try to configure it in a standard way and watch TV then. It just won’t work.

Remember that you have to use username osmc and password osmc for tvheadend… thats required of VLC also…and any other player to access tvheadend web or stream.

-H

when the “play” on channels/epg or services in browser don’t work , you need to clean a cache of browser .

in tvheadend/webif , you have a log /debug at the lower right corner .

@HarryL Yes, I entered the login and password as osmc, otherwise I wouldn’t be able to get into the web configuration of the Tvheadend. After all services are found I can click on any of them, but none starts playing. Just VLC icon and black screen.

@charlotte Yes, I do have the mpeg2 license since long time ago.

Does tvheadend work in kodi and are you using username/password osmc in the tvheadend client andon aswel?

tvheadend 4.0.7 /osmc work fine .
user password /tvheadend client htsp is not mandatory.(obligatory)

you should look at your tvheadend user permissions, i think thats where your problem is.

username/password is “mandatory” if you use osmc default access fil…

-H

@HarryL Still verifying, but it looks like the problem really was me not entering login and password to Tvheadend HTSP client. Sorry if it was mentioned somewhere during the installation and I missed it.
Just wondering why the login and password are necessary at all…
Will confirm once all is working.

Confirming it works now. I really had to enter the login and password to Tvheadend HTSP client. Had no clue this needs to be done. Thanks for your help and support.

and here that correct password will be rejected many times before successful stream eventually starts on VLC:

using ticket HTTP/1.1 GET /stream/mux -- 401

For the simple fact of Security and as people change username/password this option has to be given in the addon