TvHeadend Not Working


#1

Hi,

I have a Raspberry Pi2 and am running the latest version of OSMC. I have purchased an official OSMC DVB-T2 dongle. I successfully went through the initial setup process about a week ago, everything seemed to be ok, but watching channels was a bit flakey. Then on Monday I was in the middle of watching a program and suddenly started getting errors like “HTSP client no connection” and “No Signal”.

I have tried removing and reinstalling TvHeadend a couple of times using the following commands I found on the forum:

sudo systemctl stop tvheadend
rm -rf /home/osmc/.hts
sudo apt-get remove --purge armv7-tvheadend-app-osmc
sudo apt-get install armv7-tvheadend-app-osmc

Channels wouldn’t scan properly and I was still getting “No Signal” errors. I tried the above commands a final time tonight and was able to scan all expected channels, however I still get “No Signal” errors. I know that there is no problem with signal as I have plugged the exact same coaxial cable directly into my TV and have no issues whatsoever.

I have uploaded some debug logs here.
I’m about to start pulling my hair out here :wink: .

BTW the TVHeadend server and client are both running on the same RaspberryPi.

Thanks


#2

Do you have problems viewing some channels or all?


#3

In the log:

Jan 11 20:07:07 OSMC tvheadend[534]: linuxdvb: adapter 0 has tuner count 2 for type DVB-T (wrong config)
Jan 11 20:07:07 OSMC tvheadend[534]: linuxdvb: adapter 0 has tuner count 1 for type DVB-C (wrong config)

so it seems like the adapters aren’t correctly recognized or configured.


#4

can you provide a screenshot of the webif with the dvb config? (configuration -> DVB Inputs -> TV Adapters)


#5

@sam_nazarko I’m having problems viewing all channels


#6

@rantanplan1 here is the screenshot as requested.


#7

Make sure you use the Sony DVB-T demodulator for tuning


#8

why not disable the other two not used tuners… and make sure you have the dvb-t settings for that tuner correct (I’m using dvb-s so I’m not 100% familiar with the dvb-t settings)


#9

Thanks Sam, I have been using that tuner as I have been following installation instructions here


#10

I’m not too sure how to disable the other two not used tuners. I’m guessing that you’re suggesting this as it’s possible that the other two are being used by mistake??


#11

Just don’t tick the Enabled box


#12

Thanks @grahamh, just checked that in the configuration and the Sony DVB-T is the only one enabled.

Any other thoughts as to how I can fix my issue? Because as far as I can tell, I have performed all installation and setup correctly…

My thoughts at this stage are:

  1. Faulty tuner

  2. Corrupted OSMC installation

  3. Corrupted SD card

But I really don’t know tbh


#13

Some hints from my experience:

  1. These USB sticks (I have 3 of different makes) are not as sensitive as the tuners in TVs. Just because you get a good signal for your TV doesn’t mean it’s good enough for a USB stick. If I use just one stick, the signal can be be marginal - I now have an aerial amplifier to feed two sticks and TV at the same time. Also, make sure you have got decent aerial cabling. http://www.aerialsandtv.com/cableandleads.html

  2. For some reason, if you ever enable then disable the Realtek tuner things go wonky. The fix is to wipe just the hardware configs and re-tune:

    sudo systemctl stop tvheadend
    rm ~/.hts/tvheadend/input/linuxdvb/adapters/*
    sudo systemctl start tvheadend


#14

Thanks for that information @grahamh.

  1. I understand that this is the case and have read a little about USB tuner sensitivity. However I don’t feel that this explains why I had signal before and not now (also back when the signal was coming through, I was experimenting with using a UHF amplifier and it didn’t seem to make any discernible difference to the signal so I stopped using it). I feel that something else is wrong (be it hardware, software or config). When it was coming through, the signal wasn’t perfect, but it was definitely watchable. Now suddenly I am unable to get any signal at all and am unable to watch anything.

  2. Thanks for this suggestion. I don’t think I have enabled the Realtek tuner, but it’s definitely worth a try (I’m willing to try just about anything at this point). How do I re-tune without running the whole setup wizard again? Or is that what I need to do?


#15

Actually, if you already have channels scanned, there is no need to re-tune those. What I suggested doesn’t wipe the tuning data. It should (!) gradually pick up any channels you were missing.

Thought: You could also try a powered hub in case it’s not getting enough juice.

Yeah, I’ve had a few of these things. I can never actually measure any improvement in signal level, but since installing the latest I’ve never seen any picture breakup/blocking which was happening too often before.


#16

OK, I’ll give that a go when I get home tonight :slightly_smiling_face:.

An interesting thought. I’ll see if I can give that a go as well. Thanks for the suggestion.


#17

Thanks again for your suggestion @grahamh, I have run the above commands and all three tuners show up as expected. I have now enabled the Sony DVB-T however when I attempt to watch a channel it now says “No free adapter available” :confused:


#18

Really though I don’t think I should need to go in and manually remove adapters etc if I have completely removed and reinstalled the entire TvHeadend OSMC app multiple times. Each time I did that I should have been starting with a fresh instance of the program.

Also in terms of powered hubs and aerial amplifiers, I’m open to forking out money to improve signal and quality. However the key word there is “improve”. I’m not getting any signal at all and I am on my TV. So I guess I’m not really happy to spend on additional devices on the maybe that it’ll “improve” my issue.


#19

Nope, removing the APP will not remove the config at all.


#20

True, but running this command

before removing the app (which I did each time) should. Correct?