Tvheadend Permissions USB Drive


Just got my new Vero 4k+ today (very good so far!).

I am migrating from a libreelec system which ran tvheadend and saved recording to a USB drive. I have plugged the same USB drive in the new Vero and installed tvheadend (from the myosmc app). I can see the drive and have configured tvheadend to record to the USB drive. When I try to record anythign though I get:

2019-06-07 12:21:17.581 dvr: Unable to create dir “/media/59c173d7-b95e-45b2-b78f-5f9f45b71a20/rectv/Couples Come Dine with Me”: Permission denied

2019-06-07 12:21:17.581 dvr: Recording error: “Couples Come Dine with Me”: Unable to create file

2019-06-07 12:21:17.581 subscription: 0006: “DVR: Couples Come Dine with Me” unsubscribing from “Channel 4 HD”

2019-06-07 12:21:17.584 dvr: “Couples Come Dine with Me” on “Channel 4 HD”: End of program: File not created

And so on. I have tried to chmod -R 775 the rectv directory but still get the same.

Any ideas what I am missing?

IIRC, tvh files on LE are owned by user hts. Try a chmod 777 or chown -R osmc:video on those files.

Thanks. I got it with chmod -R a+w, forgotten how annoying tvheadend permissions were.

Do you know how to get tvheadend to import recordings from another tvheadend? Be nice to get all the old recordings into the new system.

You could try copying everything from .hts/tvheadend/dvr/log/. sudo systemctl stop tvheadend first.

At your own risk :wink: You may have to do a search/replace on those files if your recordings drive is not mounted in the same place.