TvHeadend picture stutter on HDTV recordings


I’ve noticed this issue since OSMC Kodi v19 was released in August 2021, I should have reported it back then but life happened…

During playback of HDTV recordings the picture will freeze momentarily, and sometimes pixellate. This occurs throughout playback, the freezing is not regular but roughly every 3 to 7 seconds. It’s watchable but annoying.

Audio playback is not affected and continues uninterrupted.

This was not an issue before v19 and I haven’t altered the TvHeadend settings other than to try different stream profiles i.e. matroska or htsp/pass.



To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Hi Sam,

I’m running the latest OSMC on a Vero 4K + with the DVB-T2/DVB-C TV dongle.

I don’t watch live TV very often but did so for the purpose of providing this feedback. I can report that the stuttering also happens when watching live TV.

For the first 5 minutes or so everything is fine and then the stuttering begins and then continues, this is consistent after rebooting, everything is okay for a short while and then the issue begins.

Here is the log:




Can you reproduce this with a recording?



Yes. In fact I was recording the channel at the same time as watching. I’ve just looked at the playback and can see the stuttering.


To clarify: if you play a recording, you also get the stuttering.
If so – it would be good if you could share a small recording with us so we can try and reproduce the problem



There are tons of these errors

tvheadend[2852]: TS: DVB-T/634MHz/BBC TWO HD: H264 @ #101 Continuity counter error (total 21)

which belong to a OSMC DVB-T2 dongle (Sony variant)

[    6.454121] usb 1-2: dvb_usb_v2: found a 'OSMC Engineering DVB-T2' in warm state
[    6.563680] usb 1-2: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[    6.563711] DVB: registering new adapter (OSMC Engineering DVB-T2)
[    6.585677] i2c i2c-0: Added multiplexed i2c bus 1
[    6.585688] rtl2832 0-0010: Realtek RTL2832 successfully attached
[    6.613144] i2c i2c-0: cxd2841er_attach(): I2C adapter ffffffc05736e0b8 SLVX addr 6e SLVT addr 6c
[    6.617542] i2c i2c-0: cxd2841er_attach(): attaching CXD2837ER DVB-C/T/T2 frontend
[    6.617553] i2c i2c-0: cxd2841er_attach(): chip ID 0xb1 OK.
[    6.617566] usb 1-2: DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))...
[    6.617950] usb 1-2: DVB: registering adapter 0 frontend 1 (Sony CXD2837ER DVB-T/T2/C demodulator)...
[    6.652956] r820t 1-003a: creating new instance
[    6.659972] r820t 1-003a: Rafael Micro r820t successfully identified
[    6.660006] r820t 1-003a: attaching existing instance
[    6.681349] r820t 1-003a: Rafael Micro r820t successfully identified
[    6.738381] rtl2832_sdr Registered as swradio0
[    6.738389] rtl2832_sdr Realtek RTL2832 SDR attached
[    6.738393] rtl2832_sdr SDR API is still slightly experimental and functionality changes may follow
[    6.745154] Registered IR keymap rc-empty
[    6.745429] input: OSMC Engineering DVB-T2 as /devices/platform/c9000000.dwc3/
[    6.746032] rc rc1: OSMC Engineering DVB-T2 as /devices/platform/c9000000.dwc3/
[    6.751557] rc rc1: lirc_dev: driver ir-lirc-codec (dvb_usb_rtl28xxu) registered at minor = 1
[    6.751573] usb 1-2: dvb_usb_v2: schedule remote query interval to 200 msecs
[    6.761562] usb 1-2: dvb_usb_v2: 'OSMC Engineering DVB-T2' successfully initialized and connected

So, is the receiption of the signal fine (good antenna, signal quality)?
Have you tried to shutdown the Vero, unplug the Vero’s power cord for 20 seconds and then restart the device again (cold start for Vero and OSMC DVB-T2 dongle)?

Hi Sam,

Here’s a sample:


Hi Jim,

Thank for this. Yes the reception is great, in fact we had a new aerial fitted only a few months ago and if I’m watching using the TV’s tuner I see no such problems.

I tried cold starts as you described but the issue returns each time.

The issue started after Kodi v19. Would the higher power requirement of v19 mean less is available for the TV dongle?


DVB-T2 is pretty power hungry.
What USB hub are you using?

I’ve never used a hub, the TV dongle is plugged into one of the USB ports on the Vero 4K +. There’s no mention anywhere that the TV dongle requires a USB hub. It was working fine until v19 so there was no reason to suspect it wouldn’t after the upgrade.

I would try powering the dongle externally to rule out this being the cause of the problem.


I’ll need to get one, will the OSMC powered hub do the job? Will everything recover seamlessly on restart in the event of a power failure?

Can you clarify what you mean by this? Do you get regular power cuts?

In any case, it should be fine.

Hi Sam, we very occassionally have power cuts. We don’t watch a lot of live TV, mostly recordings, so it would be good to know that everything should be fine instead of relying on me remembering to check and only realising all is not okay is when none of your planned recordings have worked!

Right, now I get you. If the power comes back on, then it should be OK.

As with any power loss, there’s a potential for filesystem corruption, but this is usually minimal. Obviously if you have a power cut during a recording, that recording won’t turn out OK.

Thanks, I’ll shell out a few £££’s on an OSMC hub!

It will be with you on Friday.

1 Like

(You ordered an EU power supply for a UK address). I’ll assume that you want a UK one instead.

Thanks Sam, yes I do want a UK supply. I need to slow down…