Tvheadend PVR client not starting on reboot

Good evening all, I’m hoping someone could help me out a little here.

I’m running the latest version of OSMC on a Raspberry Pi 2. It is using the OSMC app store version of Tvheadend server connected up to an HDHomerun Connect recording all the PVR content off to an Apple Time Capsule. All devices are on the same network segment and the time capsule is mounted up through CIFS on the OSMC device as an automount through fstab.

Everything has hung together fine up until recently. Now however if I reboot the OSMC device it will intermittently (around 50% of the time) not start the PVR client. When in this state it is still enabled as an addon and the TV section of Kodi settings shows it as still being enabled. While in this state, the tvheadend backend is actually still running and recording, plus I can still connect to it through http on port 9981. Disabling the PVR from the TV section of settings and enabling it again will bring things back to life or another reboot ‘may’ clear it.

It appears to be something to do with the client not always starting properly at boot time.

I have two sets of logs uploaded, first is of a reboot where the PVR client started fine:-
The second is of a reboot when the client failed to start properly:-

The one obvious difference to me is that the not working boot has the following messages in the output.
htsp: [ osmc | Kodi Media Center ]: Write error – Broken pipe
htsp: [ osmc | Kodi Media Center ]: Disconnected

Any suggestions or other logs I should be looking at to help troubleshoot this further?

Have you tried enabling “wait for network” in the MyOSMC pi config settings?

I’ve just tried turning on that setting, it appears to have slightly improved things however I am still getting the failure around 25% of the time.

Actually, I spoke too soon, from some more testing the problem seems to reoccur at much the same rate as before.

Is there anywhere I could add an artificial delay i.e. within a script so that the load of Kodi could be delayed by say 10 seconds?

Should not have any impact on a service that is using localhost

Thanks for the suggestions so far, is there anything else that could help troubleshoot this, or as alluded to above any artificial delays I could put in anywhere?