TVHeadEnd recording padding not working


#1

Hi all,

I have the current version of OSMC set up on a Raspberry Pi 3B+ with TVHeadEnd installed via the app store. From the terminal this appears to be version 4.2.6-1.

Everything seems to work except when I try to set padding for the timer recordings (i.e. adding 5 minutes pre-recording and 10 minutes post-recording) - the system acts as though this hasn’t been configured and records based on the EPG timing alone (which often clips a few seconds at the start and end). However, it does use the recording path specified in the config.

I have a model 2B Pi as well with Raspbian + TVHeadEnd (ver. 4.2.7 from the tvheadend repo) that doesn’t appear to have this problem.

Has anyone else experienced this issue? Does anyone know if this is particular to TVH 4.2.6, or the build on OSMC?

Thanks.


#2

Yes, I’ve experienced this in the past.

If I remember correctly, I think I found that the settings in Kodi > Settings > PVR & Live TV Settings > Recording override those you’ve setup in TVHeadend.

Try playing with the Default Start Padding Time and Default End Padding Time settings.

https://kodi.wiki/view/Settings/TV/Recording


#3

Turn on ‘View level: Expert’ and in your recording profile, make sure ‘Use EPG running state:’ is unchecked.

In Configuration/General I recommend setting User interface level: Expert, as this shows you a lot of useful setup options.


#4

Thankyou both for the suggestions. I will test them today and post the results.


#5

To activate the expert view level is an excellent first step to understand what’s going on with your TVH.

Besides the padding values there is also a “warmup” value which i.e. allows you prepare the system if using a NAS/external hdd which needs some time to wake up from sleep/hibernation.

If you create a NEW (don’t look at an old once) planed recording within TVH, you can directly check whether the padding is reflected, here an example news broadcast, original starts 19:00 and ends 19:20:

If you “edit” such upcoming recording entry, you can also check in expert view level what profile was used in real when it was created:


#6

Thanks for covering all those details, Jim - much appreciated.

I’ve used TVHeadEnd 3.x for a while on my Pi 2 with Raspbian, but the view levels in version 4 are new to me (only recently updated my Pi 2 to 4.x when I set up OSMC on the Pi 3). Certainly haven’t used all its features.

I noted that the “Use EPG running state” was checked on the Pi 3 (OSMC) but not on the Pi 2 (Raspbian). Turned it off on the Pi 3 and did test recording today; this appears to have resolved the issue.