TVHeadend recording

Hi. Vero 4k records live tv through TVHeadend with no problems when recording path is set to /home/osmc. If I change that path to my external drive /media/Sandisk SD/Recordings, when I press record, recording instantly stops. Have tried this with drive formatted as exfat and OS journaled but no luck. Feels like a permission issue but have no clue about this really. Haven’t touched any other settings in the recording tab on TVHeadend yet. Any help would be appreciated.

TvHeadend probably has an error log if something like this happens


Ok thanks Sam. I’ll find out how to submit an error log and send it when I get a minute. Thanks.

i can solved your problem, it was mine too. First your sandisk is probably an hard disk? first for me i had format my external hard disk on ext3, like a linux partition.

Then you should be known what is the id of your sandisk, type the command dmesg
mine hard disk is on sda5, but put a write path to sda5 doesn’t work
so i used filezilla to understand, check on directory media your hard disk name
and just rename on tvheadend interface the recording directory by /media/HARD_DISK_NAME/
for raspbian strech it’s the path required
for osmc for me it works only when i did this path

I tested on raspbian strech it was also this methods

See my pictures

Hi. Thanks for your suggestion. Formatted SD card as suggested but think I got lost somewhere along the way. Did use fdisk after formatting to get disk name, but I’ve no idea if this is the way to do this. Anyway, it didn’t work but appreciate the support- a lot of this is way over my head!
Am I right in thinking that TVHeadend on vero 4k won’t record to external disks unless they’re formatted as ext3?

Just so you know, you can upload images directly to this forum.

It should be able to recognise most formatted drives (FAT32, exFAT, NTFS, ext4)

Cool. Do I just need to enable debug logging in kodi, then try and record something, then generate a debug log and paste the link here? Or is there a different process for TVHeadend? Thanks.

If you login to TVHeadend’s web side at default port 9981, you see at the bottom right a button which expands the TVHeadend log; when expanded another button appears at the bottom right which enables TVHeadend debug log.

So, to get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • enable the debug log in TVheadend’s web side at port 9981 (see above)
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here
  • publish the TVheadend debug log as well using cut’n paste but please, use the format method like “Preformatted text” or “Blockquote”.

Hope, we can help you, soon.

Really helpful, thanks! Work has taken over at the minute but will do this as soon as I get a minute sometime this week. Thanks again.

Oups dude i was talking of OSMC installed on one Raspberry PI3.
Can you use a SSH and connect with putty to Vero 4k? for example you could try to set command on putty called “dmesg” to see peripheral connected on pi, as hard drive but for your case SD card i don’t know if it could be displayed. And try to check if there is a directory on /media? by the way ‘filezilla’ or ‘putty’.
And i had just formatted the hard drive with a tool on windows to format on Ext3 not anymore.

Had similar problem on my pi before. Make sure to reboot after changing recording path to hard disk.

Then clear the epg data so it reimports it from tvheadend. Settings --> TV --> Guide --> Clear Data

1 Like

Aaah! Thanks man…rebooting and clearing pvr data after changing recording path did the trick. Now recording to my exfat formatted SD card. Thanks again.

1 Like

Yes, TVH is very bad about changing settings on the fly. Glad you solved it.

Your welcome glad it worked for you :slightly_smiling_face:

Can mark my answer as the solution to help others