Tvheadend recording

Tvheadend (stable) has been working great for me on vero 4K+, but with one long-standing issue I haven’t been able to solve.

Recording most programmes either manually or using a timer works fine. However, it seems that if there is a colon in the programme title (e.g. ‘Snooker: World Championshp Extra’) then a timer will start just before the programme starts but shortly after says recording completed and doesn’t create a file. If I manually record the same programme it records no problem.

I’ve played around with file permissions/ removing unsafe characters, but would imagine nothing would be recording if this was the problem.

Interestingly, If I set a timer for a programme with a colon in the title from within tvheadend UI itself, the recording works.

Happy to send logs - would I just enable debug logging in tvheadend UI then send logs as normal through my osmc? Thanks.

If you think it’s a TVHeadend issue then the issue is best reported to them, but chucking some logs here (Kodi and TVH) might give us some ideas



Sorry Sam, assumed this was a kodi issue as timers work from within tvh ui, but that’s probably not the case. I enabled debugging in tvh and pvr component specific logging in kodi as well - hope that’s correct.

Set timer at 11:25am, to record programme at 11:30am. Didn’t record. Then manually recorded it straight after which worked.

Let me know if it’s not your problem and I’ll post in tvh forums, thanks.

Apr 23 11:30:00 osmc tvheadend[2968]: dvr: Unable to create dir "/media/SD Card/TV recordings/Blue Peter: Superstar Sigrid": No such file or directory

What is the filesystem of the SD Card?

Exfat, but I also changed recording location to my ext4 formatted external hard drive and get the same problem, only with programmes with a colon in the title.

Have you seen this config block at the right bottom of my screenshot or is that what you mean with tried “unsafe characters”?

Yes, sorry should’ve been more specific. I’ve ticked remove unsafe characters and windows specific file names, and also tried changing character set to UTF-8. Is it worth trying the other options you have ticked (don’t include title in filename and replace white space options)? Thanks.

Since I’m using only tvheadend + tvheadend HTSP client (kodi addon) to record and playback TV streams, I don’t care about the real file name on the file system and let thvheadend create a name without any title information.
Within kodi I you do not see the real file name within the “PVR & Live TV” menu but the title of the broadcast.

Thanks JimKnopf. Tried checking those extra boxes (don’t include filename/white space) but no luck. However, with those extra boxes checked, and switching my recording location to an ext4 formatted drive- which I’d tried before without success - programmes with a colon in the filename are now recording properly from a timer. Appreciate your time!

1 Like

Glad to hear this is solved.