TVHeadend Server not installing

Just tried to install the TVHeadend server.

When I go to My OSMC -> App Store -> TVHeadend Server -> Install -> Apply

I get a pop-up window labelled “OSMC Error” With the message: “Error installing: armv7-tvheadend-app-osmc (4.2.4-3) Please report this on the OSMC forum.”

So now what?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Sam,

I didn’t know initially that the TVHeadend server was available in the App Store. So I tried using some online “tutorials” for installing it. This involved a lot of commands thru putty - and it didn’t work.

I suspected that those attempts (along with some leftover garbage from 3rd party addons I had tried a while back and quickly uninstalled) was fouling up the tvheadend install. So I wiped my SD card and did a fresh install. That did the trick and I was able to download the addon without problem.

But in a post to me on the official Kodi forum, you told me:

“You can then log in to the interface at http://IP-OF-KODI:9981 using osmc as both username and password.”

You did mean that I should use the browser (Firefox) on my laptop on the same network as my RPi to access that, right?

When I try, I get a “Server Not Found” error message. :disappointed:

Yes. What is the IP address of your pi?

Yeah, after I posted that and re-read it, I realized that I had input “ip-of-kodi” and not the actual ip address… :flushed:

2 Likes

Okay. Apparently I do not have the drivers for my usb tuner installed.

It’s a Hauppauge 955D, plugged into a powered usb that is connected to the RPi.

I assume that I need to install the drivers thru putty.

Please post logs as Sam asked above, then we can advise you.

As I said, I did a fresh install of OSMC. It cleared up the mess and allowed me to install the TVHeadend server wthout problem. I was also able to access the TVHeadend server setup without problem.

NOW, my problem is that when I am in the setup window, I cannot set the TVHeadend server to use the Hauppage usb tuner. From what I’m reading in the TVHeadend help, I need to install the drivers for the tuner before I can proceed with the setup.

OSMC itself isn’t giving me any problems now. So I don’t understand why you need any logs.

logs include the output from dmesg which tells us whether your stick is recognised and is looking for firmware it can’t find.

Installing the drivers isn’t as straightforward as running a command.

OK. That makes sense. Thanks for having the patience and taking the time to explain it clearly to the technically challenged.

I’ll upload the logs when I get home.

The TVHeadend configure doesn’t show the setup wizard now.

The logs are at: https://paste.osmc.tv/qohulovuya

It runs automatically the first time you open the page. After that, it can be run by clicking on an icon in the navigation bars at the top.

It doesn’t look like your stick is being recognised (ie as you say no driver). Maybe @sam_nazarko can see if it can be added.

From the Hauppauge Support page - http://hauppauge.com/pages/support/support_linux.html#pi

WinTV-HVR-955Q

Raspbian Jessie The current version of Raspbian Jessie comes with Kernel 4.1 and it already includes support for the Hauppauge WinTV-HVR-955Q.

Raspbian can be downloaded from https://www.raspberrypi.org/downloads/raspbian/

Please check the Raspberry Pi community on how to install and run an operating system on the Raspberry Pi.

All you need to do is connect the WinTV-HVR-955Q to a USB port on the Raspberry Pi.

You will also need the firmware which is not included with Raspbian Jessie. You can download the Conexant cx231xx USB firmware v4l-cx231xx-avcore-01.fw for the WinTV-HVR-955Q from Linuxtv.org http://linuxtv.org/downloads/firmware/#conexant You will need to copy the firmware file to /lib/firmware and reboot the system. That is all you need to load the TV tuner firmware and get the WinTV-HVR-955Q device detected.

So do I just download that file, put the SD card back in my laptop and copy over the file? My Hauppauge is a WinTV-dualHD (Model 955D).

You can only access the boot folder when putting the sd card in your laptop.

Download the program winscp on your laptop, install and run it and connect it to your raspberry pi ip. Input the username and password and connect. From there you can then drag and drop files from laptop over to the /lib/firmware folder

I downloaded the file ( v4l-cx231xx-avcore-01.fw) to my laptop. Established a connection over WinSCP. Went to drag and drop the file into lib/firmware as per the Hauppauge instructions. BUT THE FILE WAS ALREADY THERE!

If that’s the file for the tuner’s drivers, why isn’t it already setting up the drivers?

Strange. Although it needs more than just the firmware files, if they are there it looks like it’s suppposed to be supported in the kernel. Probably only Sam knows.

Edit: just a thought - you do have a lot of stuff hanging off USB. Could you try with just the dongle attached in case it’s just not getting enough power?

I’m using a powered usb hub because the RPi couldn’t supply the power directly needed to run my Passport HHD.

I did have a keyboard dongle and a usb drive plugged directly into RPi. I removed them from the RPi and rebooted Kodi. It stopped a message popping up at startup that the TVHeadend HSTP Client was unavailable.

I still do not see the Hauppauge tuner in the TVHeadend server setup. I’m going to read up a bit more on the server setup process. It doesn’t seem very intuitive or user friendly. So I may just be misunderstanding how to access the tuner.

If the tuner doesn’t show up in Configuration->DVB Inputs->TV Adapters in the TVH Webui it is not currently supported. I think someone’s looking into that for you.

According to the Hauppauge support page, their tuners are supported in Linux.

http://hauppauge.com/pages/support/support_linux.html

I just can’t figure out how to get it into Kodi. Apparently Haupauge has developed a PPA to help load them in Linux.

You had best let the devs do it. If it’s not supported, the kernel will have to be recompiled.