Tvheadend with OSMC DVB-T2 dongle issue

I was having trouble getting live tv working on my Rpi with Tvheadend. I kept getting the ‘pvr client starting up’ message. I thought a new DVB-T2 dongle with a fresh install may help so I purchased the official OSMC one.

Issue I am having now is that the dongle briefly appeared in Tvheadend and I was able to to scan for new services but after a while it disappears and the Panasonic chip is no longer visible.

I have tried a number of options, just using the one dongle eg. disconnecting all other devices from the usb’s (external drive and 2nd DVB-T dongle) in case it was a power issue; even a fresh install of OSMC but nothing seems to be working. (all updates and latest versions being used)

I still get the ‘pvr client starting up’ message and despite having 2 DVB dongles (August210v2 and OSMC) both of which should receive HD broadcasts I seem to be struggling to create a reliable setup and can only receive a subset of the channels found on the initial scan.

log files are at

Any help gratefully received.

What are you using to power the Pi?
Are your HDDs externally powered?

From the system log it does look like a potential power issue, which may also explain the issues on the August dongle.


Thanks for the quick reply.
I am using an official Rpi power supply.
I have disconnected the external drive and now mapped the recordings folder to a shared drive over nfs.
The only things connected to the USB ports are the 2 DVB tuners.

Are you able to try a single tuner at once?
Do a cold boot too so I2C gets reset.


Will do.

Screenshot from 2018-02-07 16-30-59

Still not showing in TVheadend

Try deleting .hts/tvheadend/input/linuxdvb/adapters/* (from memory) after stopping tvh then restart.

1 Like

You can return it back to us and we can take a look. However, if you can, it might be an idea to try it on a computer or different device.

It would be surprising if both the August and OSMC adapters were faulty.

I will test with just the August adapter and let you know.

I tried Grahamh’s suggestion of deleting the adapters folder. That seems to have worked for now. Will check to make sure that the adapters still appear after a few restarts.

Thanks for the suggestions and the hard work on the software.

Have you got both dongles working together? So far, I haven’t dared using both adapters (I have the same ones) at once because of power issues and a weak TV signal but wondering whether to buy an amplifier splitter.

BTW, there seems to be no reason to enable the Realtek tuner if you are not on cable. You can’t use both Realtek and Panasonic at the same time AFAICT.

They are both showing up in TV adapters; I have not yet tried to record one program whilst watching another on a different mux. I will try that later and let you know.

I have had the August adapter for about a year and had been using that to get live tv reception so it did scan for channels fine, but now when I scan using it, it doesn’t seem to pick up any services, however, if I scan with the OSMC adapter and then unplug it and use the August one it seems to work just fine.

I have also gone down the amplifier splitter route - mainly due to the fact that I still wanted to have an antenna going straight into the tv and like you was worried about weak reception to the raspberry Pi…

@grahamh I have successfully managed to record on one mux and watch on another, however I have not yet managed to record on two different muxes at the same time.

Just using the OSMC dongle? I couldn’tmake that work. If you’ve got both dongles plugged in it should work for watching and recording.

No, sorry - using both dongles (although I have enabled both the Panasonic and Realtek chips - as you say probably only one of them works at a time).
I should be able to record on the August one but it doesn’t seem to like it. I will have to do some more testing.