Hi…I tried to install TVHE on my Vero 4k+ but in the osmc App Store my remote doesn’t seem to work.
I tried to install via terminal, the ‘aarch64-tvheadend-app-osmc’ is the one I think I should install, but I get the following:

osmc@vero:~$ sudo apt install aarch64-tvheadend-app-osmc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 aarch64-tvheadend-app-osmc:arm64 : Depends: dvb-firmware-osmc:arm64 but it is not installable
                                    Depends: python-minimal:arm64 but it is not going to be installed
                                    Depends: gzip:arm64 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Is this the right version for Vero4k+?
Any ideas?

It seems the armv7 version is what you need:

osmc@vero4tv:~$ dpkg -l | grep tvh
rc  aarch64-tvheadend-app-osmc:arm64     4.2.6-1                        arm64        TVHeadend for OSMC
ii  armv7-tvheadend-app-osmc             4.2.6-1                        armhf        TVHeadend for OSMC

I’ve no idea why I have the aarch64 version here but it’s the armv7 that’s installed and working.

I’ll give it a whirl, thanks Graham.

1 Like

@grahamh That one installs fine so I’ll mark this as solved, thanks.
Out of interest does the aarch64 one even work? Does it offer any performance improvements?

I think we must have tried it once and probably got tangled up in 32-bit drivers. there are no performance issues - TVH runs on Pi0 I believe.

That’s right. In the end we got it to work as expected :slight_smile: