UDP stream not working in 16.1

here is debug log
22:54:48 T:2998515584 DEBUG: CAnnouncementManager - Announcement: OnAdd from xbmc
22:54:48 T:2998515584 DEBUG: GOT ANNOUNCEMENT, type: 2, from xbmc, message OnAdd
22:54:48 T:2998515584 DEBUG: Loading settings for udp://239.255.2.2:1234/
22:54:48 T:2998515584 DEBUG: CPlayerCoreFactory::GetPlayers(udp://239.255.2.2:1234/)
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: system rules
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: matches rule: system rules
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: mms/udp
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: matches rule: mms/udp
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: adding player: DVDPlayer (1) for rule: mms/udp
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: lastfm/shout
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: rtmp
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: rtsp
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: streams
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: matches rule: streams
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: aacp/sdp
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: mp2
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: dvd
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: dvdimage
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: sdp/asf
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: nsv
22:54:48 T:2998515584 DEBUG: CPlayerSelectionRule::GetPlayers: considering rule: radio
22:54:48 T:2998515584 DEBUG: CPlayerCoreFactory::GetPlayers: matched 1 rules with players
22:54:48 T:2998515584 DEBUG: CPlayerCoreFactory::GetPlayers: adding videodefaultplayer (1)
22:54:48 T:2998515584 DEBUG: CPlayerCoreFactory::GetPlayers: for video=1, audio=0
22:54:48 T:2998515584 DEBUG: CPlayerCoreFactory::GetPlayers: for video=1, audio=1
22:54:48 T:2998515584 DEBUG: CPlayerCoreFactory::GetPlayers: adding player: DVDPlayer (1)
22:54:48 T:2998515584 DEBUG: CPlayerCoreFactory::GetPlayers: added 1 players
22:54:48 T:2998515584 DEBUG: Radio UECP (RDS) Processor - new CDVDRadioRDSData
22:54:48 T:2998515584 NOTICE: DVDPlayer: Opening: udp://239.255.2.2:1234/
22:54:48 T:2998515584 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
22:54:48 T:2998515584 DEBUG: CRenderManager::UpdateDisplayLatency - Latency set to 0 msec
22:54:48 T:2998515584 DEBUG: LinuxRendererGL: Cleaning up GL resources
22:54:48 T:2998515584 DEBUG: CLinuxRendererGL::PreInit - precision of luminance 16 is 16
22:54:48 T:2632211264 DEBUG: Thread DVDPlayer start, auto delete: false
22:54:48 T:2632211264 NOTICE: Creating InputStream
22:54:48 T:2632211264 NOTICE: Creating Demuxer
22:54:48 T:2632211264 DEBUG: ffmpeg[9CE45B40]: Using network protocols without global network initialization. Please use avformat_network_init(), this will become mandatory later.
22:54:48 T:2998515584 DEBUG: ------ Window Init (DialogBusy.xml) ------
22:54:55 T:2830842688 NOTICE: INDIGO NOTICE: Checking for Malicious scripts
22:54:59 T:2910845760 DEBUG: script.module.osmcsetting.updates : - blurp 65 - DialogBusy.xml
22:55:13 T:2615450432 DEBUG: Thread JobWorker 2615450432 terminating (autodelete)
22:55:18 T:2632211264 DEBUG: Error, could not open file udp://239.255.2.2:1234/
22:55:18 T:2632211264 ERROR: OpenDemuxStream - Error creating demuxer
22:55:18 T:2632211264 NOTICE: CDVDPlayer::OnExit()
22:55:18 T:2632211264 DEBUG: OnPlayBackStopped: play state was 1, starting 1
22:55:18 T:2632211264 DEBUG: Thread DVDPlayer 2632211264 terminating
22:55:18 T:2998515584 ERROR: Playlist Player: skipping unplayable item: 3, path [udp://239.255.2.2:1234/]
22:55:18 T:2998515584 DEBUG: Playlist Player: one or more items failed to play… aborting playback
22:55:18 T:2998515584 DEBUG: ------ Window Init (DialogOK.xml) ------
22:55:18 T:2998515584 DEBUG: ------ Window Deinit (DialogBusy.xml) ------
i waiting for adequate advises to solve this problem

Nope, not a full and complete log. Provide the output of grab-logs -A.

can u explain what i should do to use grab-logs -A?
where i should write it?

You’ve been provided instructions MANY times!

You have consistently failed to provide the information we require to properly diagnose and fix your issue. Please posts logs or we’ll have to close this thread. http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

If you can’t use the simple tool we’ve provided in MyOSMC, then use https://osmc.tv/wiki/general/accessing-the-command-line/

To easy say - go to url and read.
im not english speaking and dont understand all correct. i dont understand what command grab-log do. when i need to start it before start kodi or before press button to open stream. i dont understand why i need start nano and paste-log command - what paste-log do? where it paste log? if u so smart or so familiar with subj - im very happy for u. But i `m a little be different.
First of all people here requests for debug log, After request ununderstandable grab-log and after it redirect me to URL where wrote strange things for me.
Correct FAQ to make it understandable all people around the world, not only english speaking.

i done grab - http://paste.osmc.io/xukukuyica
but i didn`t find anything different my first post here.

OSMC and all what’s around it is made free of charge for the people, by the people, who are spending (or sometimes literally wasting) their free time to provide help on either forum or wiki site. If you don’t understsnd clearly what is written on any of these sites, you could for example use google translate or ask someone here who knows both english and your native language for help. I think the only requirement for somebody to help you in this matter would just be neing polite.

Oh, you managed to provide logs as I was writing this. Great, good for you.

Does the stream play on any other device? Your log does not have debugging enabled so there is more information that could be helpful that we are not able to see until you create debug enabled logs.

yes it plays on my macbook under clear kodi 15.2

23:56:51 T:2607061824   ERROR: CCurlFile::Open failed with code 404 for http://download.osmc.tv/kodi/addons/jarvis/metadata.themoviedb.org/metadata.themoviedb.org-3.9.3.zip.md5
23:56:51 T:2607061824   ERROR: Open - failed to open source <http://download.osmc.tv/kodi/addons/jarvis/metadata.themoviedb.org/metadata.themoviedb.org-3.9.3.zip.md5>

You also seem to have some problem with your device accessing the internet. This could easily be the reason your stream doesn’t work.

to write “use grab-log -A in command line to upload log to our server” - i understand this are a lot of letters.
i dont write rules here and i cant influence on politic here - but it is so stupid to clog up server resources unneсessary information which i cannot use in search process.

IF WE’RE ASKING FOR IT, IT’S NECCESSARY… You are making it very difficult to assist you.

i thunk u invent new idea fix
oot@BAGs:/home/osmc/.kodi/temp# ping discourse.osmc.tv
PING discourse.osmc.tv (159.253.212.199): 56 data bytes
64 bytes from 159.253.212.199: seq=0 ttl=56 time=57.844 ms
64 bytes from 159.253.212.199: seq=1 ttl=56 time=58.089 ms
64 bytes from 159.253.212.199: seq=2 ttl=56 time=57.909 ms
64 bytes from 159.253.212.199: seq=3 ttl=56 time=57.901 ms

i provide 50 lines of information. it is enough to understand problem - u request 1500 lines where this 50 are in.
it is wrong way in my case, imho

Are you sure? Then why don’t you understand the problem?

Your upd link doesn’t even play in VLC here, so I assume a problem with the stream. Contact your stream provider. Good luck…

Thank for help, body. You found day before yesterday data and localize my today problem.
Thanks a lot for help like that. It help me very well.

Glad to be of assistance buddy!

The problem is… pls dont give me your stupid advises if u dont understand that trouble in advisers like you.
I have internet on device and my provider works fine.

Ok, how about I give you a 30 day vacation from discourse.osmc.tv? Enjoy!

1 Like