UI reverting to 480p

Since the last osmc update my 4K+ is occasionally changing the resolution to 480p when I stop the video playback. The Ui was 1080p by default when I boot it up, stays at 1080p when I play some 1080p content but then drops down to 480p when I press stop. I can’t reproduce it so I haven’t been able to get any logs yet. Any ideas what might cause it whilst I try to get some logs?

If you have 480p whitelisted and refresh rate change enabled, and you play a 480p video the UI also gets set to 480p because that is what you told it to do. If you set the refresh rate change to “on start” then your UI will be whatever resolution and frame rate of whatever you played last. If you set it to “On start/stop” instead the UI will only be lowered as your playing the video and then when you stop the video it will revert to the resolution in your settings.


I have seen this twice in the last couple of weeks. Both times when watching a 1080p film at 24fps. At the end of the film the gui is in some horrible low res mode. A reboot fixes it but it’s annoying.

I normally have my gui at 1080p



Can you and/or @KevinPeters please post some debug logs so we can use your settings and attempt to reproduce this?

Obviously, if you can grab the logs while the GUI is 480p after an incident, so much the better.

Sure. I’m happy to do that next time I see it.

Do I need to be running debug on before the event or is it enough to switch it on next time I see the 480p event happen?



Can you just grab some logs now with debugging so we can see your settings and how Kodi is selecting resolutions.

If you get an event, we need debugging to be on when it happens. If you don’t want that annoying on-screen debugging info, then put a file called advancedsettings.xml in ~/.kodi/userdata which contains the following:

<?xml version="1.0" encoding="utf-8"?>

I’m in work today but will do that next time I get a chance. Might not be until the weekend though sorry.


My problem is as Mat describes. I have added the extra logging, will see if I can capture it!

1 Like

I just experienced this same behavior for the first time today. If I find any consistent way to reproduce the glitch, I’ll enable debugging and trigger it to get the logs, but I’ve only seen it once in the month since the June update was released, so I’m guessing it’s a rare edge case. As with @mlavende, I experienced it when playback stopped on a 1080p/24 file, but that constitutes 95% of what I watch, so it doesn’t seem likely to be related to the resolution or framerate of the file you’re stopping playback on.

As a note, I fixed the problem by quickly toggling the resolution on the GUI settings screen, then saying no when it asked for confirmation on the change, at which point it snapped back to the correct 1080p that’s configured in the GUI settings. There shouldn’t be any need to reboot to rectify the resolution.

Thanks Alamei. Yes, I can confirm that a reboot isn’t strictly needed to fix the problem. I have also experienced it watching TV (a mix of 1080 and 576p).

I spent about 20 minutes yesterday trying to get it to do it, but no luck! Will keep trying.

Go to Settings -> Display and enable HPD Lock.

This doesn’t work for me. I set HPD Lock with 1080 but it reverts back to 720

Can you upload a log?



Your log doesn’t show the GUI reverting to 480p. I’m not sure how this is related to OP?

That’s correct it reverts back to 720 thought set to 1080

Then the issue isn’t the same as OPs at all.
It looks like you uploaded the logs when your TV was off, so there is no EDID data, and I can’t see what resolutions your TV is advertising support for.


sudo fw_setenv hdmimode 1080p50hzforce
sudo fw_setenv outputmode 1080p50hzforce

to make 1080p persistent.

In future, please start a new post for unrelated issues.

1 Like

I haven’t forgotten about this BTW, it just hasn’t happened in the last week!

I don’t know why it’s happening but have made an adjustment which may prevent it.

Hello, I have this 480p issue, often when I played 4k videos. May this be fixed with next update? Thx