Unable to add more media sources from computer

In August, Graham Hall very kindly told me how to connect my Vero 4K to a computer.

He said to create a new computer user that had to logon with a username and password.

Then, in Vero, after clicking 'Add videos > None > OK, typing:

smb//:querty:1234@MYPOOT/m. This worked perfectly well! (‘m’ is a USB3 drive in an external case)

I just tried to add another hard drive - not USB but internal this time - on the same computer, using the slightly different command: smb//:querty:1234@MYPOOT/s, but it didn’t work.

Drive S, just like M, is very thoroughly shared, and its security properties modified, just like I did with M the first time.

I also tried it with a big ‘S’ - no better. I also tried it with C drive. Nope again.

I must be doing something wrong :cry: Could some kind person please advise?

Well I think first think to check is if s really is shared and available. If you have verified all of that on your PC the only reliable way to check from OSMC would be via the command line. If you are ok to access the command line I would be happy to guide you through the steps.

Is this a typo? It should be:

smb://querty:1234@MYPOOT/m

Thanks for the offer, fzinken, but I think bmillham might have spotted the error.

bmillham: oh dear, I feel like a real klutz!

I copied Graham’s instructions when he posted them, and then later I copied my note in more detail. And transposed the // and the : :blush:

So the first note was correct but I used my incorrect copy when I tried to add the extra drive today.

Thank you, thank you! :smiling_face_with_three_hearts:

Sorry, I have one more question.

I must have changed a setting when I was fiddling!

The lower pic shows what the Movie screen used to look like.
The top pic shows what it looks like now. Thumbnails and Categories etc. Yuk :stuck_out_tongue_closed_eyes:

How can I get it back to the ‘Before’ look?

The lower picture is showing TV Shows, and you don’t have any scanned in. The top picture is showing your scanned in movies. That’s what you would expect to get.

You can probably go into the settings and into appearance and configure the skin to disable things you don’t want to see

Oh. That would explain why I kept getting a ‘can’t contact server’ message. I don’t want to download these ‘movie cover pages’ or whatever they’re called. How can I turn that business off? Please?:kissing_heart:

Make sure that Settings -> Media -> Library -> Update library on statup is off

" Make sure that Settings -> Media -> Library -> Update library on statup is off"

Thanks, but it was already off.

Then the only way that media has been added to the library is if you manually did it.

Yes, I probably did, not disputing that.
But now I want to have that page looking like it did before. Must be a setting for it somewhere…

You will need to delete the library if you don’t want it anymore.

It’s located at ~/.kodi/userdata/Database and the file is MyVideos107.db. Just SSH in, stop Kodi and remove the database.

sudo systemctl stop mediacenter
rm ~/.kodi/userdata/Database/MyVideos107.db
sudo systemctl start mediacenter

will do the trick.

You may need to add your sources again after doing this.

If I delete the library, won’t I lose my drive contents lists?

Yes, as I said you may will need to add your sources again.

OK, I get it.

Now, all I need is a crash course that’ll enable me to follow you previous instructions, i.e.,

Right now, I have absolutely NO idea where to start. Sorry :thinking:

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

If you haven’t set up a lot of things yet, it may be easier to just reinstall OSMC from OSMC.tv/download.

Sam, thanks. I was wondering about reinstalling.
Afterwards I’d have to reset my local configurations, wouldn’t I?

You can take a backup, but by restoring it, you’ll likely be restoring the changes you’d made before.

Sam