Unable to add to or edit video sources

After persevering with KODI 19 the last OSMC update gave me the perpetual sad face problem so I took the opportunity to do a complete new install of the latest version. I appreciate that the following could well be KODI issues but having posted there and got no help, I thought to repost here to seek guidance.
On a Raspi 4. I set up my sources, no problem, and subsequently scraped all TV shows and Movies. I want to change my TV scraper but am totally unable to do so. It used to be very easy but now not so much. The ability to edit or add Video sources is MIA.
Under Expert settings; clicking on ‘Videos’ I get a list of: Movies; TV Shows (the sources I have already set up); Files; Playlists and, Video Add ons. The only ‘context menu’ I get on a long click is ‘Add to Favorites’. Clicking on Movies or TV shows takes me to the normal list of those as if I had gone through the main menu. Clicking on Files I get ‘Path not found or invalid’ but with no option to see the path or edit it. I cannot see how the Files path is invalid as it allows Movies and TV Shows to operate correctly. I am at a complete loss as to what has gone wrong or of what I am missing. I am reticent to wipe the lot and start again. It is a three day job to set up my TV shows and Movies the way I want them.
There is no menu choice I have found, since I set them up originally, to edit or even add sources for Videos.

I also noticed yesterday that my choices to change resolution is severely limited.
I have not included a log as yet because there is no one thing happening at a given time; just a general overall crippling of the system.

Any help gratefully accepted.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

That sounds like you context menu’d the widget and that is expected behavior. You have to go into videos>files or access it from settings>media>library>videos>.

I have never seen or heard of this error. Logs may provide some insight. The file in question can be accessed either through ssh or by installing samba using the My OSMC add-on and then accessing it from a PC. The file in question is ~/.kodi/userdata/sources.xml and if this has network paths that require credentials you will also need to check ~/.kodi/userdata/passwords.xml. The former stores the file paths and the latter path substitution pairs to insert the credentials.

And if you reboot with the display turned on?

“You have to go into videos>files or access it from settings>media>library>videos>”

Exactly what I did. No change either way, no path to edit.

Network paths and credentials are correct.

“And if you reboot with the display turned on?”

That fixed that issue, I now have a full list of resolutions rather than the 4-5 I was stuck with.

https://paste.osmc.tv/avufuqojuw

Can you switch to the Estuary skin and see if that makes a difference?

No, as in I tried and got the switch then “Do you want to keep this change”, then a pop-up with:

“Skin Shortcuts.
Unable to build menu.”

“OK” Reverts back to OSMC skin.

I have tried Rapier and Amber previously to try and resolve, but while they appeared to load correctly, they made no difference to the problem.

This error message is expected behavior as Estuary doesn’t use the skin shortcuts add-on. You should have been able to hit OK and then select the confirmation for the skin change right after though. The only thing that I can think of is corruption of your SD card. It isn’t your sources.xml and the error message isn’t actually coming from that file. I actually swapped out my sources.xml for yours and was able to access the context menu to allow modifying the sources without any error message (it of course hung if I actually tried to navigate inside one of them since they don’t exist on my network). It looks to me like there is both an error in your database and it’s missing a file from your skin. I would dig up another SD card and do a clean install on that and see how you get on.

Not really what I wanted to hear, but it does make sense. This SD card is not the original, from the previous 19 install. I may not use that one either but get a completely new card and start from scratch. Thanks for your help I’ll revisit this once new card is setup and I have fixed issue, or not.

1 Like

I think I’m encountering this issue on my two Vero 4k’s. I cannot find the “set source/content” button for some weird reason.

In the menu where I’m expected to “set source/content”, I only see “Edit library nodes”.

Where is that? Maybe also show a screenshot of the menu you get.

Ah, I figured out. User error, lol. facepalm Please ignore me.

So, my issues do seem to have been caused by a faulty MicroSD card. Replaced with a new Sandisk and it is now running faultlessly.

1 Like

If you want a better MicroSD card, you can try this.

I’ve used it successfully in a handful of RPIs. However, my Tesla dashcam eats them every 4 months; Sandisk will warranty it.

Got pissed off with constant SD failures, hence why we sell an OSMC one.

7 years in a Nextbase 512GW and still going strong.

1 Like

TBH, OP should just buy a Vero V and call it the day. :slight_smile:

Or not! I’m happy with my Raspberry Pi 4 thanks!