Unable to browse NFS or SMB

Hi. Hadn’t used the Vero in a while but it now won’t play any movies I’d scraped previously, and indeed when I try to add a new remotely mounted folder I’m unable to browse - when I select either NFS or SMB whereas previously I was pretty sure you were presented with a network file tree to navigate in either case there’s a short second or so pause but the same menu stays on screen - it’s as if I hadn’t selected NFS or SMB.
I had a quick look in the log and seeing:
2024-02-15 18:38:49.195 T:2851 error : GetDirectory - Error getting nfs://
2024-02-15 18:38:49.195 T:2851 error : CGUIDialogFileBrowser::GetDirectory(nfs://) failed
2024-02-15 18:39:06.004 T:2851 error : GetDirectory - Error getting smb://
2024-02-15 18:39:06.005 T:2851 error : CGUIDialogFileBrowser::GetDirectory(smb://) failed

I’ve network access because I was able to ssh into the box to access those log files.

I feel it’s something obvious but can’t think what I’ve done.

If I try to play a previously added movie I get:
2024-02-15 18:34:34.875 T:3089 info : Creating InputStream
2024-02-15 18:34:41.120 T:3089 error : NFS: Failed to mount nfs share: (nfs_service failed)

The Vero V was suggesting I update so tried that - update seemed to be applied ok but still same issue.

Any suggestions welcome.

On my synology NAS I have to allow access to the shared folder by adding the ip address of the vero under nfs permissions.

Thanks though I don’t think the Vero is getting as far as that, ie I can’t even browse to the NAS.

How old is the NAS?

SMB browsing can be a bit dicey and it’s better to enter the exact share details directly.

If it was NAS problem would you expect the above to fail ?

Try autofs, its reliable in my experience, look here Autofs


Exactly! I disabled nfs on my Synology DS223 and tried to browse “Network file (NFS)” … and I get

2024-02-16 07:47:04.808 T:3721    error <general>: GetDirectory - Error getting nfs://
2024-02-16 07:47:04.808 T:3721    error <general>: CGUIDialogFileBrowser::GetDirectory(nfs://) failed
2024-02-16 07:47:09.086 T:3721    error <general>: NFS: Failed to mount nfs share: / (nfs_mount_async failed. Failed to start connection. Failed to start connection. Invalid address:. Can not resolv into IPv4/v6 structure.)
2024-02-16 07:47:12.092 T:3721    error <general>: GetDirectory - Error getting nfs://
2024-02-16 07:47:12.093 T:3721    error <general>: CGUIDialogFileBrowser::GetDirectory(nfs://) failed

Let us know if you need help to get and upload debug logs. Without logs there is no real chance to further troubleshoot the situation.

Thanks for the pointers. I was wrong in my initial assumptions and it does indeed look like it’s an issue with the NAS.
The bit of information I omitted because it hadn’t occurred to me that it was relevant was the NAS recently came back from repair - I inserted the hdd’s which I kept hold off any everything was back to normal with all my files intact. However as part of the repair they swapped the motherboard and updated the firmware.
Googling has revealed other Qnap NAS users who’ve lost access from OSMC via NFS following a firmware update. Now I just need to work out why unless anybody knows ???
Thanks again.

Have you checked the simple thing that the IP Address hasn’t changed as with the motherboard most likely the MAC Address changed.


You’re right the IP address allocated by DHCP is likely to change if the MAC address has, but I can’t even browse to it so it’s not just that.

I’m pretty sure now it’s a Permissions thing with the QNAP since the firmware update. I’ll take it up with QNAP support next week. Other people seem to gave hit the problem and solved it, but I’ve tried the things described here Solved - Unable to see files in Kodi via NFS after Upgrade - QNAP NAS Community Forum without success.

In the meantime, whilst I can’t browse to a SMB location, I was as Sam suggested able to explicitly type this in and I’m back in business.

Are there any issues with using SMB (I’m on full 4K rips) rather than NFS ?

SMB is just fine to use

There is special QNAP section here: https://kodi.wiki/view/NFS … but I don’t know whether this matches your model.