Unable to change download directory of Transmission-daemon

I have my first Raspberry Pi 2 with OSMC installed for use as a media player. I have been trying to get Transmission working for torrents but after following every different guide i could find have had no luck.

After much tinkering i have been able to get transmission installed and am able to access the webpage GUI.

However as soon as i change the default download directory to my external hardrive and reload transmission-daemon I end up with a 403 error accessing the web gui.

I assume it is some sort of permission thing but i have spent hours trying every guide for permissions and cant seem to get it to work.

Can anyone help me?

I want to change the download to
/media/My\ Book/Video\ Files/Downloads

these are the drive permissions

drwxrwxrwx 1 osmc osmc 0 Jun 15 19:31 torrent_complete
drwxrwxrwx 1 osmc osmc 0 Jun 15 19:31 torrent_incomplete

"alt-speed-down": 50,
"alt-speed-enabled": false,
"alt-speed-time-begin": 540,
"alt-speed-time-day": 127,
"alt-speed-time-enabled": false,
"alt-speed-time-end": 1020,
"alt-speed-up": 50,
"bind-address-ipv4": "",
"bind-address-ipv6": "::",
"blocklist-enabled": false,
"blocklist-url": "http://www.example.com/blocklist",
"cache-size-mb": 4,
"dht-enabled": true,
"download-dir": "/var/lib/transmission-daemon/Downloads",
"download-limit": 100,
"download-limit-enabled": 0,
"download-queue-enabled": true,
"download-queue-size": 5,
"encryption": 1,
"idle-seeding-limit": 30,
"idle-seeding-limit-enabled": false,
"incomplete-dir": "/var/lib/transmission-daemon/Downloads",
"incomplete-dir-enabled": false,
"lpd-enabled": false,
"max-peers-global": 200,
"message-level": 1,
"peer-congestion-algorithm": "",
"peer-id-ttl-hours": 6,
"peer-limit-global": 200,
"peer-limit-per-torrent": 50,
"peer-port": 51413,
"peer-port-random-high": 65535,
"peer-port-random-low": 49152,
"peer-port-random-on-start": false,
"peer-socket-tos": "default",
"pex-enabled": true,
"port-forwarding-enabled": false,
"preallocation": 1,
"prefetch-enabled": 1,

how are you changing the settings?
Remember that with transmission you CAN NOT change the settings.json file while the daemon is running.
Or better, you can, but your changes will be trashed at next restart.
The right way is -> stop daemon -> change settings -> start daemon


i’ve never seen a 403 error, so maybe you are simply writing your path bad (too many backslashes for my likes…)

Check which user is running transmission, use
ps axl | grep transmission
It may be you aren’t reading the configuration file

Thanks for the reply. @pborman

Here’s the info from that command. Not sure what it means though?

4 109 260 1 20 0 28324 4116 SyS_ep Ssl ? 0:09 /usr/bin/transmission-daemon -f --log-error
0 1000 575 564 20 0 2136 556 pipe_r S+ pts/0 0:00 grep transmission

Thanks for the reply, I have not been stopping the daemon, but have run

sudo service transmission-daemon reload

which i thought makes the daemon re read the settings and not trash those settings.

The 403 only happens on the webpage Gui as below

403: Forbidden

Unauthorized IP Address.

Either disable the IP address whitelist or add your address to it.

If you’re editing settings.json, see the ‘rpc-whitelist’ and ‘rpc-whitelist-enabled’ entries.

If you’re still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details.

The ps axl command shows you are running transmission daemon as user 109, while you are user 1000, osmc.

I would guess you are not reading the configuration file in /etc/transmission-daemon as you are not running as root. Transmission will look for its configuration file in /home/osmc/.config/transmission-daemon and if it can’t find that it uses hard-coded inbuilt defaults.
The default settings only allow access to the web interface from the local machine, which is why you get the 403 error.

Several ways round it, I would suggest running as osmc…
chown - R osmc:osmc /etc/transmission-daemon
Then edit /etc/transmission-daemon/settings.json so that rpc-whitelist allows access from your local network, “,192.168.0.*” should do it.
Then sudo nano /lib/systemd/system/transmission-daemon.service Change User to osmc
Add -g /etc/transmission/daemon
to the end of the ExecStart line after the --log-error
Save the file, then stop the daemon and start it again under the new user.

After this commit:

You will no longer need to manually allow IP addresses in order to access the web interface.


Hi guys just installed Osmc on new pi 2 and transmission via the app store.
It’s running fine with the web interface and also via transdroid.

However I’m just trying to change the default download directory and this install is a lot different from the previous Pi1 B transmission.

I ssh in and when I type in sudo service transmission-daemon stop
I get transmission-daemon: unrecognized service

There is no file /etc/init.d/transmission-daemon

I found the setting.json file in /home/osmc/.config/transmission-daemon folder and have changed the download directory but I suspect the permissions of the folders need to be updated.

Sorry I’m a novice - what do I need to do to update the permissions ?
If there’s a sticky on this please let me know - couldn’t find it via the search.


by the way for permissions this is what I got for a ps axl | grep transmission :smile:

4 1000 420 1 20 0 82824 10768 SyS_ep Ssl ? 5:04 /usr/bin/transmission-daemon -f --log-error --allowed ...
0 1000 980 469 20 0 3740 1560 pipe_r S+ pts/0 0:00 grep transmission

OK IT’S ALL GOOD. Just did a reboot and download folder was updated.

Apologies if this is the wrong place to post this but I’m having similar problems.

I’ve just tried to change the location that torrents download to. I did this via the transmission web interface. I clicked on settings (spanner icon) and set the path to /media/mumsdrive (I’m trying to make a torrent client/media player that my mum can use in her house so she stops torturing me to download stuff for her!)

Everything was looking good until the torrent reached about 13% then the torrent stopped and I got an error warning:

Error: Permission denied (/media/mumsdrive/thenameofthetorrent)

So I changed the directory back to the default. Rebooted. Started a fresh download. I again got to about 10% and then:

Error: Permission denied (/transmission/rpc/thenameofthetorrent)

What am I doing wrong?

Currently I have done nothing to ‘Mumsdrive’. I simply allow OSMC to automount it on boot.

I installed transmission through the app store, I have ran updates, I’ve done everything through OSMC’s GUI. Nothing has been done via the command line as of yet.

I do have the SSH client running and can access the RPi2 this way.

I’d be incredibly grateful for all and any help.

/etc/transmission-daemon/settings.json is wrong