Unable to connect to a network share via smb

Added a new PC system (win 7 Pro 64 bit) to my home network and I’m trying to share a new folder (videos) with my Vero 4K and also my Raspberry Pi3.
I believe all settings are correct for sharing the new folder, I am sharing several other folders with other systems on the network using both the Vero & Pi3.
I also have kodi on another PC system on the network and have no problem accessing the new folder with it.
I am able to access the new folder from all other systems on the network.
I have reviewed and followed the Kodi SMB/Windows wiki.
I have reviewed the other system settings that are working and the folder settings within the Vero & Pi3, they all appear identical, yet I am unable to access the new folder.
When I do try to add it I get:
Thru Add Videos
Error
Invalid Argument
Unable to connect
Couldn’t retrieve directory information
This could be due to the network not being connected

Thru File Manager
Error
Connection refused
Remote share
Couldn’t connect to network server

Login via ssh and run smbclient -L <IP of win7 machine>

I don’t know how to login via ssh
I have little to no experience with Linux

Please go to the wiki for this:

https://osmc.tv/wiki/general/accessing-the-command-line/

Follow the tip from @Chillbo also yo need to install smbclient via sudo apt-get install smbclient

It is rather out of date. Have you read this File sharing with a NAS, media server, windows share or other device?

I had a network share issue with my Vero 4K a month or so back although mine was from a Windows 10 Pro machine (it might be the same SMB patches have been applied by MS to Windows 10 and 7), this is the solution I found…
On the Vero 4K or Pi go to settings then services then SMB client and set the maximum protocol version to none.
I hope this helps

First, I want to thank everyone for their time.
All were helpful.
By going to settings, then services, then SMB client and setting the maximum protocol version to none did the trick.
I was prompted for user name, password and then moved the slider to remember.
Following grahamh’s article I then reset the SMB client setting back to smbv3 and the systems continue to share.
This worked for both systems (Vero 4K and Pi3).
Thank you!

1 Like

This does not seem to work either - the same message appears (unable to connect to network)