Unable to connect to mysql when using USB ethernet

After connecting D-Link DUB-1312 USB 3.0 Gigabit ethernet (via USB 2.0 connection of Vero 4k); everything works fine except connection to mysql. Does not seem to work. If I disconnect and use internal fast ethernet it works after restart (no config change). Switch around and mysql is dead.

Any solution for this?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

https://paste.osmc.tv/roceduyifi

22:49:02.396 T:2861757184 WARNING: DoWork - Unable to open video database. Can not save file state!

22:50:01.805 T:4057985792 ERROR: Unable to open database: xbmc_video107 [2003](Can’t connect to MySQL server on ‘192.168.0.210’ (101 “Network is unreachable”))

But Why? It is there…

osmc@osmc:~$ ping 192.168.0.210
PING 192.168.0.210 (192.168.0.210): 56 data bytes
64 bytes from 192.168.0.210: seq=0 ttl=64 time=0.759 ms
64 bytes from 192.168.0.210: seq=1 ttl=64 time=0.442 ms
64 bytes from 192.168.0.210: seq=2 ttl=64 time=0.814 ms
64 bytes from 192.168.0.210: seq=3 ttl=64 time=0.727 ms
64 bytes from 192.168.0.210: seq=4 ttl=64 time=0.843 ms

You still seem to have the eth0 cable connected. It’s getting an IP address on eth0 (192.168.0.26) but that is later being withdrawn due to the presence of the USB network adapter usbnet0, which receives an IP address of 192.168.0.24.

Remove the eth0 cable and reboot. You already seem to have “Wait for network” set, so Kodi shouldn’t start until usbnet0 comes online.

Nothing connected on eth0, and I only have one cable available. It was moved from eth0 to USB ethernet, and Vero4k was rebooted. The log you see is from the reboot.

Then I’d guess that it has been given a fixed IP address, since it’s showing 192.168.0.26 on eth0. If so, remove the fixed address.

Must I turn off eth0 (uncheck enable adapter); shut down vero4k (remove power); then connect to usbnet0 and start again?

A reboot should be sufficient, once you’ve disabled eth0.

Still same issue; I disconnect usb-device; connected eth0 and rebooted. I then deactivated eth0, rebooted; then shut down of device; disconnecting power; connected usb-ethernet device (with ethernet cable); plugged in power - still same issue.

  1. Booted up with eth0 connected (without any USB-ethernet device attached)
  2. Deactivated eth0 (in menu)
  3. Turned off Vero4k (disconnected power cord)
  4. Attached USB-ethernet adapter with ethernet cable attached.
  5. Connected power cord
  6. Enabled usbnet0 in menu
  7. Rebooted
  8. Still same isse :frowning:

All you needed to do was to disable eth0 and reboot.

Please provide new logs so I can see what’s happening.

But wired network only got one setting (applies in UX for both eth0 and usbnet0). This does not compute for me…

So how did eth0 have an IP address of 192.168.0.26 and usbnet0 have an address of 192.168.0.24?

If you want to use the USB network adapter, you need to make sure that eth0 has no fixed IP address. That probably means that usbnet0 will need to get its address from DHCP.

eth0 had manual ip set; I managed to fix it by attaching eth0 again and switching it to use dhcp. Afterwards I disabled eth0 before attaching usbnet0 (activating that). Then restart.

Thank you for assistance! Love Vero4k and OSMC :slight_smile: Full solution in 1 hour; don’t think any of the big cooperations can beat that.

Reason for usbnet0 is because I now can run all UHD blu-ray files without any stuttering. It is soooo smooth.

Thanks for the feedback. Happy you now have it working.

Please mark the thread as being solved

1 Like

Thanks Tor – as always give us a ping if you have any problems.

Sam

1 Like