Unable to disable Airplay "Videos" and "Pictures" support

When I go to Settings - Services - Airplay - Enable Airplay “Videos” and “Pictures” support and uncheck the option to disable it and then reboot the setting appears enabled the next time I check it.

On the latest version of OSMC - just did apt-get dist-upgrade.

I’m wanting to use Airplay for audio from my iPhone on iOS 9.3.3 which apparently works now on 16.1 - see OSMC Kodi 16 Airplay - #2 by Joep

Make sure you’re on the latest version and upload the logs if issues persist.

Thanks for the reply.

Rebooted several times and the problem continues.

Logs at http://paste.osmc.io/qukajubova

Can’t see any clues, but it’s not a debug log.

Whoops sorry - here are the logs with debug etc enabled http://paste.osmc.io/radebilivu

Your apt log shows you have a partially installed kernel. If you check this forum category you’ll see some advice on how to fix that.

Future versions (this one included) are more robust with HFS+ filesystems.

02:03:57 T:2821339968   DEBUG: webserver: request received for /jsonrpc
02:03:57 T:2787785536    INFO: CZeroconfAvahi::clientCallback: client failure. avahi-daemon stopped? Recreating client...
02:03:58 T:2998413184   DEBUG: GOT ANNOUNCEMENT, type: 8, from xbmc, message OnRestart

Not really sure what that means, but worth checking output of service avahi status when this happens


There was a failure in a dist-upgrade earlier but I had solved it after performing:

umount /boot
fsck.hfsplus -f /dev/sda1
mount -o force,rw /dev/sda1 /boot

I searched for ‘partially installed kernel’ and found Failed update, now "no updates available" - #4 by DBMandrake which led to the following commands and output:

root@osmc:/home/osmc# dpkg --configure -a
root@osmc:/home/osmc# apt-get -f dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I checked the output of:

root@osmc:/home/osmc# service avahi status
* avahi.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)

However I can log into the server with ssh via

ssh osmc@osmc.local


AirPlay is pretty broken in recent iOS versions however, even for audio. But Kodi should at least present options correctly.

root@osmc:/home/osmc# service avahi-daemon status
* avahi-daemon.service - Avahi mDNS/DNS-SD Stack
   Loaded: loaded (/lib/systemd/system/avahi-daemon.service; enabled)
   Active: active (running) since Wed 2016-10-19 02:05:02 BST; 1h 5min ago
 Main PID: 1320 (avahi-daemon)
   Status: "avahi-daemon 0.6.31 starting up."
   CGroup: /system.slice/avahi-daemon.service
           |-1320 avahi-daemon: running [osmc.local]
           `-1325 avahi-daemon: chroot helper

Oct 19 02:05:02 osmc avahi-daemon[1320]: Loading service file /services/udisks.service.
Oct 19 02:05:02 osmc avahi-daemon[1320]: Network interface enumeration completed.
Oct 19 02:05:02 osmc avahi-daemon[1320]: Registering HINFO record with values 'I686'/'LINUX'.
Oct 19 02:05:02 osmc avahi-daemon[1320]: Server startup complete. Host name is osmc.local. Local service...7170.
Oct 19 02:05:02 osmc avahi-daemon[1320]: Service "osmc" (/services/udisks.service) successfully established.
Oct 19 02:05:02 osmc avahi-daemon[1320]: Service "osmc" (/services/ssh.service) successfully established.
Oct 19 02:05:02 osmc avahi-daemon[1320]: Service "osmc" (/services/sftp.service) successfully established.
Oct 19 02:05:05 osmc avahi-daemon[1320]: Joining mDNS multicast group on interface eth0.IPv4 with addres....1.5.
Oct 19 02:05:05 osmc avahi-daemon[1320]: New relevant interface eth0.IPv4 for mDNS.
Oct 19 02:05:05 osmc avahi-daemon[1320]: Registering new address record for on eth0.IPv4.
Hint: Some lines were ellipsized, use -l to show in full.

OSMC does show the options correctly, but only until reboot

More testing shows that the Airplay audio works after unchecking the Airplay “Videos” and “Pictures” support toggle until OSMC is rebooted - when it’s toggled back on.

(Airplay audio only works if the Wait for Network flag in MyOSMC is on though.)

Be great if the toggle could stay off after rebooting.