Unable to get OSMC to scan media. Unable to set content type

Got my files mounted remotely via NFS. (Assumption: OSMC only needs read/execute to the media libaries?)

However for the life of me, whilst osmc can manually browse the folder and play media, it wont scrap the libary, or allow me to set a content type on it or a search. Even when i hit “update libary” it flashes “preparing” in the top for maybe half a second.

i’ve tried both with remote DB (which works) and by removing advancedsettings.xml for local DB and i get the same results.

Its been a long time since i last used these boxes am i not looking in the right place/forgetting a setting somewhere?

Debug log here: https://paste.osmc.tv/aleyilahag


I suggest doing a full back up and reinstall (Reinstalling OSMC - Vero 4K - OSMC) and restore your settings.

You seem to have quite big gaps between updates.

Regards Tom.

yeah it was massive gap. Its never been reinstalled since i bought them

Ok thats fine, ill do a re-install, thanks very much!

1 Like

As a follow up, this did resolve my issue.

Not sure if because putting me back on default skin, or the process of plugging in a keyboard to do backups etc, reminded me to press “C” which allowed me to then select content (which was none, and why it wasnt working) to the right one.

Either way, this is solved. thank you!

1 Like