Unable to hear audio when watching TV through KODI using HD Homerun

This issue has occurred for at least the last two updated. My Vero 4K+ is on the latest update (Buster). Since Buster was imminent I decided to wait till I posted this.

Anytime I watch a TV station (using a HD Homerun) through the Vero 4K I get no audio when the channel is broadcasting Dolby digital (AC3). If the channel is broadcasting AC3 (2 channel) the audio works flawlessly.

Here is the logs. https://paste.osmc.tv/atebunoqoc

I enabled logging… rebooted twice and immediately selected NBC which broadcasts the digital audio. Maybe in the logs you can see what I did.

  1. Started the channel NBC (6 channel AC3 with audio passthrough) and have no sound.
  2. Selected secondary audio channel on NBC (2 channel AC3 with audio passthrough) and have sound although my digital receiver is not decoding it.
  3. Disabled audio passthrough (2 channel AC3 without audio passthrough) and I still have sound.
  4. Selected primary audio channel on NBC (6 channel without audio passthrough) and I no longer have sound.

I thought it may be an issue with the TvHeadend Service. So I disabled TvHeadend, and installed the HD Homerun PVR. I have the same issue with that PVR as I do with TvHeadend.

Interestingly enough, when I record NBC I can watch with 6 channel audio (AC3) with audio passthrough with no issues.

Well your TV strangely enough only reports PCM capability so none of the passthrough formats should work.

PCM, 2 ch, 32/44.1/48/96/192 kHz, 16/20/24 bit

So unless you have any information that your TV supports any digital input via HDMI you would need to disable all Passthrough in your audio settings.

and set channels to 2.0.

What digital receiver are you using and how do you have it connected?

I guess it’s one of these https://www.silicondust.com/

The TV can absolutely passthrough digital audio. It passes through the audio for everything except for live TV. As already mentioned, the recorded channel, when played back, has audio with audio passthrough.

I have a LG 43UM7300PUA TV. The Vero 4K+ is directly connected via HDMI to the TV. The audio is routed via optical cable from TV to the digital receiver. I am using a HDHomerun Quattro.

Apparently, there is a setting on the TV that allows me to adjust the audio input on the HDMI channel. My options are PCM and bitstream. Under both options, I have no sound from a live TV.

I also downloaded the HDHomerun app for KODI. When I play live TV through the app, I get audio passthrough sound.

To reiterate, I always get the sound I am looking for except when I play live TV through a PVR using the built-in TV tab in KODI.

Toslink only supports two PCM channels. Please set your audio to two channels with only AC3 being allowed for passthrough (plain DTS might work as well) and select the option for AC3 transcoding.

Please see the following wiki for more information about how to setup your audio properly…

https://osmc.tv/wiki/general/audio-hardware-and-software-configuration/

That isn’t true. I get full Dolby Digital and DTS 5.1 sound through the optical cable to my receiver. It works flawlessly except for live TV using a PVR.

That is true, always has been true, as it is part of a defined standard. If you configure as advised then you should get 5.1 channel output to your audio device via bitstream over the toslink connection. The channels setting in Kodi is not how many audio channels that will be output but rather only how may PCM channels. These are not the same thing. The wiki I linked to should be helpful in the understanding of how this works.

2 Likes

Up to a point. It is just possible the OP’s TV is taking 6-channel PCM and coding it into AC-3 for its S/PDIF output.

The real puzzle is why recordings behave differently from live TV. There’s an awful lot of messages in those logs so it’s difficult to see what’s going on but I’ll see if I can see anything useful there.

Later: I’m lost in log-spam. Could you @wbeard52 please turn off all component logging (so just leave the basic debug logging on), re-start Kodi twice and repeat playing a live stream and then a recorded stream.

Thank you for your help @grahamh and @darwindesign.

I now understand toslink only have “two lanes” to travel on. In those two lanes are the six channels my digital receiver is using to provide audio.

I have done as asked and here are the logs. https://paste.osmc.tv/tavatexaqu

My steps:

  1. Started NBC with audio passthrough and 5.1 sound. – No sound.
  2. Started recording of channel. (The name was the same as a previous recording on that channel so this specific video didn’t record)
  3. Played back the recording with same audio setup (previous recording made on same channel). – Digital sound as reported by my receiver.

You still have # of channels at 5.1:

Number of channels: 5.1 ===> Default: 2.0
Dolby Digital Plus (E-AC3) capable receiver: true

Try changing it to 2.0, and set E-AC3 to false.

I made the channel change and the sound worked with 5.1 audio. I appreciate your time and your help.

My question is this…
Why did the audio work before for all the other media except for live TV?

It depends on what content you were playing before.