Unable to mount mmcblk0p2

hello, i just restarted my rpi 2 and got this message, tried manually fsck but didnt help. what to do next?

would check if that card is good at all i got that message

i can read the first partition not the second one, i copied it content

Not sure what you mean with this comment? Anyhow I suggest you check your SD Card from another PC best with Linux running (can use a Linux Live CD) to ensure that that partition and the content is all fine.

I meant i run su dd to create an image of the sd card’s p2. I can also mount and list everything. Now o just want to know if the sd card is damaged for good. I cant format it nor delete its partition

What do you mean you can’t format/delete the partition? Because you don’t want to loose it or because the command gives you an error?

because the command gives an error. this morning woke up and put the sd card on a usb stick and it works perfectly now how do i make it boot from the usb instead of the sd card?

i’m sure its something that’s stuck druing last boot that’s causing this, since i can read the content pf the card if i hook it up to a USB stick