Unable to mount shared folder

Hello guys!

I’ve tried to mount a shared folder using this how-to description , but I can’t get it to work. I’ve tried changing the version, the users.

I added this row to fstab:
// /mnt/proba cifs x-systemd.automouint,noauto,rw,iocharset=utf8,username=mark,password=asdasd,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=3.0 0 0

When cd into /mnt/proba i get this msg:
-bash: cd: /mnt/proba/: No such device

Running smbclient -L with the flags returns this:

OS=[Windows 10 Home 17763] Server=[Windows 10 Home 6.3]

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Távfelügyelet
    C$              Disk      Alapértelmezett megosztás
    D$              Disk      Alapértelmezett megosztás
    IPC$            IPC       Távoli IPC
    Kodi            Disk
    Users           Disk

Connection to failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled – no workgroup available

Any idea? Am i using wrong user/pw for authentication?


You made a spelling mistake. It should be…

// /mnt/proba cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=mark,password=asdasd,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=3.0 0 0

I’m gonna try it afternoon. Btw what username and password should I use? Is it my windows username and password? If i create a new user and allow this user to read my shared folders in Windows then from my vero should I use the credentials of this user? Thanks in advance.

The credentials are for the share you are connecting to so in your case it would be for one of the users on the Windows machine. You can use the user/pass of any user account on the Windows machine (other than guest or admin) and it does not matter if they are logged in or not.

Now i get this msg:
ls: reading directory ‘.’: Permission denied

I gave the permissions to my user.

OMG! I’m so stupid… The path where i wanted to mount it on my vero was wrong. Thank you for your help anyways.