Unable to play 4K movie


I’m unable to play 4k movies. I have previously been able to play these but have not tried in a while so can’t pinpoint the change in behaviour. I press play, the movie will stutter through a few frames and will then just freeze. What is odd is that if I play the same movie using the Plex addon it plays OK (although even then I get occasionally dumped back to the app and have to hit resume). For clarity the movie file and the Plex Media Server are on the same PC and the movie is direct playing (i.e. no transcoding is being performed).
I have uploaded a log file to http://paste.osmc.tv/evozabehiv.

Any suggestions?

I think it would help if you say which Movie you tried to play that gave you the issues to find the corresponding parts in the logs.

Lord of the Rings

2020-12-03 23:56:20.302 T:3770646752 ERROR: CAMLCodec::AddData: packet to big: 608846, probably corrupted

Is this happening with all 4k files or only specific ones?
Might actually be an issue with the audio, so would be interesting if a 4k file with none TrueHD Audio works…

I decided to scroll through all the messages to see if anyone had problems with 4K playback (it’s not possible to search for 4K when that’s the name of the device). I came across one where you pointed out that his link speed was 100Mbps instead of 1Gbps so decided to check my log and sure enough I found this entry
Dec 03 23:55:26 osmc kernel: libphy: stmmac-0:00 - Link is Up - 100/Full
This morning I scrabled around in the back of the unit and changed the cable and it now works. I think I must have swapped the cable around at some point when moving things around. The other devices are 100Mbps so would have been OK.
Lesson - cables are important. Thanks for the help. Mark this solved.

1 Like

Great find, I was about to suggest checking the network. But didn’t aligned it with the “packet to big” message.

This is actually a red herring and usually will be visible if a user pauses playback. We have to stop feeding data in to the buffer otherwise when you press Play you’ll need to wait a while for those frames to get dropped by the decoder and for the buffer to have space again.