Unable to read/access shares - connection timed out error

After installing the osmc atv-image 4.2.3-19 I added my shared drives as before. But although I can add them and see them as I go to start a slideshow or to watch a videoI get a “connection timed out” error. Then after having added a photos folder and videos folder, I tried to add a movies folder and that timed out even before I could fully add it. This has happened by sharing through SAMBA and also using the Universal Media Server on my Mac. I also sometimes get “Could not connect to network”. But I had just added the shares?!?

Samba hasn’t changed in the last update

What version did you update from?

A log may help.

Thanks for the quick response. Can I have a bit of help on how to do the log? I’m not so knowledgable about how to do that.

Our wiki contains detailed steps for providing the relevant info we need to help you.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

Got it. Will be back in touch.

After playing around with things a little more, I have a feeling that it may have more to do with the “Picture” program than SMB and the shares. When I add a video share - that seems to be working OK - but when I add shares through the Picture menu, trouble eventually ensues. It sometimes works right after adding the shared volume and subsequent folders, but then if I come out and try to go to a different folder then I get the Cannot connect to network server typer error or the Connection timed out error. Sometimes the slideshow function works but several times it did not. And of course after exiting the folder with the pictures in it and getting the Connection timed out error, I can never get back in. Even if I go to other menus and come back. Thanks for your help. The link to the log is below.

http://paste.osmc.io/evutoxasok

Correction: after posting this I went back and found some of the same problems through the Video menu. I tried to add another folder and when I arrived at the Volume name of the drive I got another Connection error. I could not add a new shared folder.