Unable to see NFS disk from Windows

I have a Raspberry PI4 to which are attached 3 external harddrives. Since the latest June update one of the drives “SharedData” is no longer visible from Windows. I can see and access all three disks from the Pi but I can’t make them all available from Windows. Please can someone tell me what has changed and how to fix it?
Thank you

This is the BLKID
/dev/mmcblk0p1: UUID=“44AC-A5C2” BLOCK_SIZE=“512” TYPE=“vfat” PARTUUID=“f3051d3f-01”
/dev/mmcblk0p2: UUID=“5f4ef101-025e-4fbf-aea0-11be0f8b40ef” BLOCK_SIZE=“4096” TYPE=“ext4” PARTUUID=“f3051d3f-02”
/dev/sda1: LABEL=“SharedData” UUID=“67dbfaa5-5070-4c0b-8f6f-db601b144de2” BLOCK_SIZE=“4096” TYPE=“ext4” PARTUUID=“ea2a721f-ac63-4b56-89f2-d5e41ad7ab32”
/dev/sdb2: LABEL=“PiDisk1” UUID=“509a816c-e862-4be0-af0e-c7b58dd91c33” BLOCK_SIZE=“4096” TYPE=“ext4” PARTLABEL=“Basic data partition” PARTUUID=“03dd13a7-1cad-4b0e-a7a1-ff4dd5ac0180”
/dev/sdc2: LABEL=“PiDisk2” BLOCK_SIZE=“512” UUID=“2CD0A7B4D0A78326” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“e055b48b-fd7c-4e28-bda9-367b74b042a4”
/dev/sdb1: PARTLABEL=“Microsoft reserved partition” PARTUUID=“6a1a30d7-2ffa-4500-834d-5eeddac4d7f8”
/dev/sdc1: PARTLABEL=“Microsoft reserved partition” PARTUUID=“50142b5a-cbec-4e8f-bcc9-da5dc83b162f”

This is the FSTAB definition
UUID=509a816c-e862-4be0-af0e-c7b58dd91c33 /mnt/PiDisk1 ext4 defaults,noatime,auto,nofail,x-systemd.mount-timeout=30 0 0
UUID=2CD0A7B4D0A78326 /mnt/PiDisk2 ntfs-3g defaults,windows_names,nofail,locale=en_US.utf8 0 0
UUID=67dbfaa5-5070-4c0b-8f6f-db601b144de2 /mnt/SharedData ext4 defaults,noatime,auto,nofail,x-systemd.mount-timeout=30 0 0

This is the exports file

Your using NFS and not smb/samba to share with Windows?

Yes. One of the other disks in NFS too and they were both being seen by Windows before the June update

Are you confusing NFS with NTFS? My query was if you were actually accessing the share via SMB and not NFS in which case the exports file isn’t where you would need to be looking but rather /etc/samba/smb-local.conf

Hi withakw.

I would see if you get any errors when mounting via powershell, please try the following commands and provide the output:

Remove-Item -Path Alias:mount -ErrorAction Ignore
mount IP.OF.P.I:/mnt/SharedData / Z:

If it does mount with no error, we can investigate further as to why it fails with GUI; also you can unmount with:

umount Z:

Thanks Tom.

1 Like

Yes I did mean NTFS. Sorry


The share which isn’t mounting is ext4, the other 2 are ntfs.

But the issue here is the sharing protocol either nfs or samba. Using /etc/exports, would imply its nfs.

Regards Tom.

This is the result of running the mount
PS C:\WINDOWS\system32> mount / Z:
mount : Cannot find a provider with the name ‘/’.
At line:1 char:1

  • mount / Z:
  •   + CategoryInfo          : ObjectNotFound: (/:String) [New-PSDrive], ProviderNotFoundException
      + FullyQualifiedErrorId : ProviderNotFound,Microsoft.PowerShell.Commands.NewPSDriveCommand

Hi @Tom_Doyle
PiDisk1 is also ext4 and that mounts successfully and I can see it from Windows. SharedData used to be visible from Windows but stopped working after the upgrade

I think that was a typo. Try…

Remove-Item -Path Alias:mount -ErrorAction Ignore
mount Z:
1 Like

I get this now
PS C:\WINDOWS\system32> Remove-Item -Path Alias:mount -ErrorAction Ignore
PS C:\WINDOWS\system32> mount Z:
mount : The term ‘mount’ is not recognized as the name of a cmdlet, function, script file, or operable program. Check
the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1

  • mount Z:
  •   + CategoryInfo          : ObjectNotFound: (mount:String) [], CommandNotFoundException
      + FullyQualifiedErrorId : CommandNotFoundException

Do you have Client for NFS feature installed? How exactly have you been accessing the drives from Windows?

Hi @darwindesign

I am just following what has already worked in the past and is already working for 2 of the devices. I am just using the map network drive to map the drive to a letter


Can you please confirm of nfs client is enabled on your windows PC? You can find it under:

Control Panel → Programs → Programs and Features → Turn Windows features on or off:

Services For NFS:-
     Client For NFS

Regards Tom.

Hi @Tom_Doyle

That isn’t an option I have to turn on or off


What version of Windows are you using and is it up to date?

Regards Tom.

Hi @Tom_Doyle

This what it says

Edition Windows 10 Home
Version 22H2
Installed on ‎19/‎06/‎2021
OS build 19045.3208
Experience Windows Feature Experience Pack 1000.19041.1000.0

I think this is a Windows Pro Option as my wife’s PC has that option and she is using PRO.


So it must have been using samba when it was working, I’m also assuming the other drives are being shared via samba aswell.

I would do as darwindesign suggested and look at:-

Regards Tom.

1 Like

The file is empty so I am not using SAMBA for the other disks